Invalid distribution name or version syntax: cryptography-1.7.1

I have been trying to set up a new instance of MIAB on a fresh 14.04 install from scaleway. I’ve had a few issues that I have no solved but my current issues is the cryptography package installation is failing:

FAILED: pip3 install --upgrade rtyaml email_validator>=1.0.0 free_tls_certificates>=0.1.3 idna>=2.0.0 cryptography>=1.0.2 boto psutil

Requirement already up-to-date: rtyaml in /usr/local/lib/python3.4/dist-packages
Requirement already up-to-date: email_validator>=1.0.0 in /usr/local/lib/python3.4/dist-packages
Requirement already up-to-date: free_tls_certificates>=0.1.3 in /usr/local/lib/python3.4/dist-packages
Requirement already up-to-date: idna>=2.0.0 in /usr/local/lib/python3.4/dist-packages
Collecting cryptography>=1.0.2
Using cached cryptography-1.7.1.tar.gz
Complete output from command python egg_info:
running egg_info
error: Invalid distribution name or version syntax: cryptography-1.7.1


Command “python egg_info” failed with error code 1 in /tmp/pip-build-c1gdlrkd/cryptography/

I have tried re-installing python, removing python2, forcing and forcing an upgrade to crypto but nothing works

Ok so from a fresh install following these instructions alone fixed all my issues:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.