Intl warning recieved

Good morning, everyone.
I keep receiving this message:"invalid literal for int() with base 10: ‘WARNING:’’, and, to be honest, I don’t know waht it means, or how to solve it.
It appeared once I created the folder on other machine, running ubuntu 22.04 and told Miab to save the backup files there (I followed the instructions on the miab page, putting the ssh key where it was supposed to be put).
Did I do something wrong? How can I solve the issue?
Any is more than apreciated.
Thanks in advance.

1 Like

It would be good if you add more details:

  • where does the error appear? How often? Is it the only line or are there more?
  • is something about the box not working?
  • elaborate what you mean with “once I created the folder on other machine, running ubuntu 22.04 and told Miab to save the backup files there (I followed the instructions on the miab page, putting the ssh key where it was supposed to be put)” Can you reproduce here the exact commands and actions you used?

It’s kinda hard to guess what’s wrong with the provided information.

Hello. My apologies.
I told Miab to save the backup on my Lenovo Thinkcenter, running ubuntu 22.04 also. There, on the Lenovo I created the folder backup, gave it full permissions, and form miab admin page chose the folder where to save the backup: it means I told miab to rsync to the Lenovo_ip, in the folder /home/dan/backup. In addition I copied the ssh key that follows in the /.ssh/authorized_keys in the Lenovo machine, so miab could connect without problems to the machine to save the backup files.
The message appears in my mailbox, as a mail from the administrator@myboxexample.com with this message only: “invalid literal for int() with base 10: ‘WARNING:’”
If I access the backup status page, through https://myboxexample.com/admin first I get the same message


After I click OK, I could change the settings for the backup (didn’t change them for now).
And here I am, asking what exactly means this error (by the way, just checked the folder and it’s empty - it has no backup file in it - so I guess something is bolcking miab to create the backup).
Any suggestion is appreciated.
Hope I answered your request. Any other info, just ask. Forgive me if I didn’t bring any other kind of info - theese are the steps I followed.
By the way, the box is working just fine. I am more than pleased with it, even if for the moment I am running it at home, on my old laptop. It’s simply working for the time being (hope it will continue like this…).
Thanks for taking interest in the matter.

It looks like there’s an issue populating the list of backups.
Is the folder /home/dan/backup already created?
Try to fill in backup instead of /home/dan/backup in the location field and see if that works.
I assume the username you’re using is dan?

Hi, there.
Sorry for the time took in answering - busy weekend. :slight_smile:
This is what I have set in the backup page:
Captura de Pantalla 2022-11-27 a las 18.01.56
The folder was created before. I gave the folder 777 permissions. If I acces the folder it’s empty.
So my guess is that miab is trying to create the backup, but, for some reason cannot write into the folder (or cannot perfor the action) - hence the error. But I just cannot understand the reason, or the error itself.
On top of it, in /var/log/syslog I cannot see anything related to backup (or maybe I don’t know how to interpret the errors that apppear in the log, which also may be more than correct). If it was of any help, I can post the result of cat /var/log/syslog | grep error. Let me know if it’s the case.

Did you try to fill in backup instead of /home/dan/backup in the location field?

Please excuse me, I didn’t understand the first time you told me to do so.
I will try it now, and let you now as soons as I have any result.
Thanks a lot.

Just put the path as you indicate, and I get the same warning message, when I try to save the configuration.
What I just did was chown to the backup folder: I sudo chown dan:dan /home/dan/backup. Maybe it’l let the miab write then… or maybe I’m wrong. Will let you know the soonest possible

I see there’s an issue with this behaviour :frowning:
Can you try if this works for you?

  • First select Nowhere in the Backup to dropdown
  • Press save
  • Then select rsync in the dropdown again
  • Fill in your hostname, path and username. Use backup in the path field.

I’m not sure this works, but it’s worth a try.

Hello.
Just followed the indicated steps.
Result:
Selecting Nowhere - result OK
Selecting rsync - the error message, path as indicated - just backup folder.
I really don’t know what is wrong here. Which log should I look into? ( honestly, I don’t have a clue… sorry for not being more helpful).

Well, it was worth a shot. I think the mentioned github is confusing your issue. I don’t have much else to try.
Per your earlier suggestion, what does sudo grep -i warning /var/log/syslog show?

Hello. Sorry for answering that late.
Here it goes the result of grep -i…

Hope it helps.

Don’t worry about being late :wink:
I’m not sure what to do next. I’ll look into it, but I don’t have enough time at the moment, so that might take a while. Hopefully someone else has a bright idea in the meantime.

1 Like

The following command is what MIAB does to verify your rsync credentials and to list your backup files (if any) that would get sent to the rsync host (in order to report the size). Replace USER, HOSTNAME, PATH with your settings (note the colon that precedes PATH).

sudo rsync -e '/usr/bin/ssh -i /root/.ssh/id_rsa_miab -oStrictHostKeyChecking=no -oBatchMode=yes' --list-only -r USER@HOSTNAME:PATH

Here’s a working response:

drwxr-xr-x              8 2022/11/28 19:18:31 .
-rw-r--r--        291,057 2022/11/28 19:17:45 duplicity-full-signatures.20221128T191731Z.sigtar.gpg
-rw-r--r--          1,095 2022/11/28 19:17:46 duplicity-full.20221128T191731Z.manifest.gpg
-rw-r--r--     23,953,497 2022/11/28 19:17:44 duplicity-full.20221128T191731Z.vol1.difftar.gpg
-rw-r--r--            270 2022/11/28 19:18:31 duplicity-inc.20221128T191731Z.to.20221128T191818Z.manifest.gpg
-rw-r--r--          1,374 2022/11/28 19:18:29 duplicity-inc.20221128T191731Z.to.20221128T191818Z.vol1.difftar.gpg
-rw-r--r--          1,684 2022/11/28 19:18:30 duplicity-new-signatures.20221128T191731Z.to.20221128T191818Z.sigtar.gpg

Try that command (with your details) and see if the response includes something like at least the first line. If the second field on any line is not a number, but something like “WARNING:”, that would cause a problem for in the code in backup.py

1 Like

There are other places that could similarly fail. But, one step at a time.

1 Like

Hello, and thanks. I just got this response to the command you so willingly shared:
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the ED25519 key sent by the remote host is
SHA256:Jzxm0QnJxVCTLcVknWMh2tGvuVtanF80GKOhwwqs3oE.
Please contact your system administrator.
Add correct host key in /root/.ssh/known_hosts to get rid of this message.
Offending ECDSA key in /root/.ssh/known_hosts:3
remove with:
ssh-keygen -f “/root/.ssh/known_hosts” -R “host_ip_redacted_even_if_I_don’t_know_why”
Password authentication is disabled to avoid man-in-the-middle attacks.
Keyboard-interactive authentication is disabled to avoid man-in-the-middle attacks.
UpdateHostkeys is disabled because the host key is not trusted.
drwxrwxrwx 4,096 2022/11/19 09:07:59 backup
And I am a bit confused, given the fact that I added on my machine, in the authorized_keys the ssh key miab provided.
So there is a problem with the miab connecting to the backup machine, I understand… Am I correct?
So, the natural question is (from my part natural, of course :slight_smile: ): how could I solve this issue?

tl;dr: Remove the known_hosts file with this command. This will erase root’s record of the hosts it has successfully connected to with SSH:

sudo rm /root/.ssh/known_hosts

The warnings are coming from SSH. They are about the machine that you rsync to (HOST). They are not about your MIAB machine. They are saying that something about HOST’s SSH configuration has changed since the first time that root successfully connected by SSH. E.g. perhaps the HOST’s name has been changed.

And, there is also a bug in MIAB. It should not be tripped up by such warnings. The regex that it uses to find lines with file and directory sizes accepts a much larger class of strings than those with valid file and directory listings…

Adding this error string to help with searches that might benefit from this thread:

invalid literal for int() with base 10: 'WARNING:'

Hello, @hughsw
I just followed your instruction: ran the command and accessed the backup page. Chose the folder and finally I got the OK answer.
Thank you so much for your help and for helping me understand, above all, where from the error came. It is true that I changed the whole host machine (new ssd, new SO) and thanks to your help I understand now why I had the error (once you pointed me in the good direction with the first command you shared in your first intervention).
Fantastic moment! Can’t say enough times how grateful I am for the help received (I’m not forgetting @KiekerJan with his helping thoughts also).
Finally, we can consider this subject as solved.
Much obliged, gentelmen, for your help.