Installing MIAB v61.1 on Ubuntu 22.04 (Hostinger VPS 1)

I am trying out Hostinger VPS 1 that has Ubuntu 22.04.
When I run the installer , it stops suddenly with this message:

Current default time zone: ‘Asia/Kuala_Lumpur’
Local time is now: Mon Apr 3 21:42:16 +08 2023.
Universal Time is now: Mon Apr 3 13:42:16 UTC 2023.

Initializing system random number generator…
Creating SSH key for backup…

Does anyone here know have a similar experience? If yes, do you know what I am doing wrong? I think the installation script has problems with Hostinger VPS 1 @ Ubuntu 22.04.

I have installed MIAB on various OSes and VPS providers, such as

  1. on Ubuntu 18.04 on VPS and it work fine.
  2. on Ubuntu 22.04 on VPS (Nanode) and it works fine.

I tried MIAB on Hostinger VPS 1 package, this problem occurs.
MIAB installation script stops after random number generator.

There have been a number of issues with ipv6 reported lately. Does Mailinabox report a ipv6 address during installation?
Also, is bind9 installed and running at the point it quits? Try apt policy bind9 and systemctl status bind9.

1 Like

Yes, MIAB installation script reports both my IPv6 address and my IPv4 address.
However, the installer suddenly stops and returns to the command prompt at the random number generator.

Do you know where the MIAB installation log files are stored? I can check the log files and paste them here, and hopefully someone can tell us what went wrong?

There’s no specific MiaB logs other then what you see on the screen. I usually try to follow the logic of the installation scripts which is why I asked about the installation status of bind9.


apt install openssh-server

and run installation again.

I think you hit this issue: