Installation quits at "Initializing system random number generator..."


#1

When i try to install mailinabox, i go through the setup, it gibes me my IP address, says
“Updating system Packages…
Installing system packages…
Initializing system random number generator…”

then it quits the setup. It doesnt tell me that the setup completed or that mailinabox is running.
I have tried rebooting and rerunning the setup, same thing
this is Ubuntu 18.04
i am running this on my own machine, not on a cloud
this is a fresh install, i have tried reinstalling ubuntu as well.
i censored my IP address in the image


Fresh ubuntu server 18.04 + LVM + LUKS - install aborts
#2

Anything in log files? “/var/log/*”?


#3

Would there be a mailinabox log file there? If so, there isn’t one. But there are other logs, I just don’t know which one to open. . https://imgur.com/gallery/DjBMu9N


#4

syslog
syslog.1 (if nothing interesting in syslog - you want log entries from the time period you attempted to install MiaB)


#5

syslog: https://pastebin.com/Fmirg7QA
syslog.1: https://www.mediafire.com/file/kuiixkidq5hr92d/syslog.1/file (its 10 MB)

since this is a fresh install of ubuntu, all of the logs are from since I installed MaiB as well. there isn’t anything interesting at all.


#6

You are installing on the desktop version of Ubuntu? That right there is your problem.

I know that the installation guide does not specifically state to use the server edition, but that is usually a given as VPS providers do not offer the desktop version (with rare exception),


#7

If you need to have your desktop version, you could try installing the Ubuntu-server onto a machine, then do a “sudo apt-get install ubuntu-desktop” to have the desktop on top of the server. Possibly, vise-versa with a “sudo apt-get install ubuntu-server”.

Not sure if the last one is an actual package, but is worth trying if you need it.


#8

I would never install ubuntu-desktop on a server (IMO, not Canonicals), I would install fluxbox and then a file manager with it, if you really really need a GUI. Fluxbox is super light, super fast, and requires almost no resources. Which on a server you will absolutely want.


#9

For whatever reason the desktop version of 18.04 has a package or configuration that is just not compatible with MIAB. Good find.


#10

Is there a way to get around this? my system wont boot when the server version is installed. It acts as if the drive is blank. Would it be okay to install version 14.04? I wouldn’t mind using the server version but my machine just can’t run it for some odd reason.


#11

A couple of questions … do you have a static IP? Is your internet connection a ‘business class’ connection with a ISP who is willing to set your reverse DNS? Will your ISP allow outgoing connections on port 25?

I am curious the motivation of running it on your machine rather than a VPS … there are going to be so many other variables involved if doing so. Starting with the three questions I asked. If any of the answers are no then … it really is not going to be worth it.

If you can answer yes to all three questions … carry on. As far as installing Ubuntu 14.04, it is End of Life in 2 months, so that wouldn’t be recommended. I was going to suggest spinning up a virtual machine with the server edition but then that brings much more complexity into things …


#12

So, I just found out that AT&T business internet connections, what I have, don’t allow uploading to Port 25. At all, for anyone. I guess I’ll have to switch my ISP. I am using my own machine to save money, and because if something goes wrong, I can fix it myself, instead of having to call up support and wait a day to fix it. I figured it would be much more simple and cheap to do so. Another thing to point out is that I’m a privacy freak.


closed #13

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.