Installation of v61.1 freezes


I am trying to install MIAB v61.1 on Ubuntu 22.04

I start installation by the standard command
curl -s | sudo -E bash

The process starts and goes fine until a certain point:

Installing Nextcloud (contacts/calendar)…
Upgrading to Nextcloud version 23.0.10

And here installation freezes. And no longer gives any response.
I tried to abort installation and start it over.

Same thing repeated 3 times. Everything went OK until ‘Upgrading…’ And silence again…

Any ideas, what might be the reason and a possible fix?
Will be grateful for any help!

Best regards,

1 Like

What VPS are you using? There have been issues with some Ubuntu templates at certain VPS providers.

1 Like


I am using VPSmalaysia. The original VPS run Ubuntu 20.04, which I manually upgraded to 22.04
One thing is non-standard: I replaced SSH port 22 with another one…

Installation is run as a non-root user with sudo. So actually the command was:

sudo curl -s | sudo -E bash


Is one of them? On Hostinger VPS 1 package despite OS being Ubuntu 22.04, the MIAB installation fails as it stops suddenly.

Is the Ubuntu 22.04 template at faulty? Is there a way to fix the problem?

What are the configuration files that are problematic and that I should try to modify?

Upgrading Ubuntu 20. to 22. is not supported by MiaB. People have reported issues with it before.

I believe it was this thread


I am afraid I don’t completely understand what kind of support is required. In my case I first updated 20.04 to 22.04 and only after that started MIAB installation…

But anyway, if some 22.04 templates do not support MIAB, is there any means to force installation of an older MIAB version?

If I start MIAB installation on, say, Ubuntu 20.04, which version will be installed?


1 Like

MiaB only supports installation on a fresh 22.04 install
If you are upgrading 20.04 to 22.04 some MiaB dependencies might not be taken into account. People have managed to make it work but it requires linux knowledge to figure out what is missing/broken and you might have issues further down the road so not recommended.

You can not install MiaB on 20.04
22.04 only supports v60 and above
18.04 only supports until v57a

if you need to install on alternative ubuntu/debian release best to look at GitHub - ddavness/power-mailinabox: A Mail-in-a-Box with extra capabilities and more customizability. Not just for power users! which is a fork

1 Like

Thanks, got it!

So if I understood things right there are two possible options in my case:

  1. Reset the VPS to 18.04 and install MIAB v57
  2. Reset to 20.04 and install Power Mail-in-a-Box

Or am I overlooking some other possibilities?

1 Like

I would ask the VPS provider why they dont offer 22.04 like anyone else in the industry and what their plans are. If it is in the pipeline in the next few weeks/months then option 1 is ok. You can migrate when it is available. I wouldn’t install a new sever to run long term on 18.04

If they are not planning anything, I would go for option 2 unless you know your way around linux.
Alternatively find another good provider.

All my attempts failed!

I talked to VPS provider’s customer support. Because they were not sure if Ubuntu 22.04 will be offered in the nearest future, I decided to try whatever works…

First, I tried Power MIAB on 20.04. Guess what? The process started vividly, but hit the same piece of rock as before: Upgrading Nextcloud!

I even tried older versions of Power MIAB. Same outcome!

Being desperate, I reset the VPS to Ubuntu 18.04. And tried normal installation of MIAB. Guess what?
Absolutely same result!

I wonder if VPSmalaysia is especially hostile to MIAB. But there were good reviews elsewhere on this forum about successfully running MIAB on VPSmalaysia.

Am I doing something completely wrong?

I will be grateful to anyone who can give any clue!



After waiting for 30 minutes or so (during which I typed the above desperate text), I was about to abort the installation…
But suddenly the process went alive and soon finished successfully…
I am now able to log into MIAB web interface.
Perhaps I was not patient enough in all previous cases?

1 Like

Gregory, I am glad it worked out and you installed MIAB successfully :slight_smile:

I hope you can share with us what version you are using?

I installed a MIAB instance on Ubuntu 18.04 successfully on I waited patiently for the install to complete and I then logged into MIAB admin panel.

What I like about VPSMalaysia is they are dual stack and support both IPv4 and IPv6.

Late to the party here, but I was going to ask how long you’re waiting. I found the nextcloud download to be very slow. In a separate terminal, do a watch ls -l on the download directory (can’t remember where it is sorry) and you can see the progress.

1 Like

Hello Grace,

Yes, Nextcloud seems to be the slowest component to install. I waited for about 30 minutes or so… And no progress messages at all. As I said, I believed the installation froze again and was about to terminate it, but suddenly the process revived and went on again…

Except for Nextcloud, the entire MIAB installs in perhaps 10 minutes or so.
I wonder what is the reason for Nextcloud being so slow and so silent.

As for your advice to watch the download directory: it may be useful once you know exactly which component will be downloaded to what directory.

I am a novice in MIAB so this was not an option for me…


1 Like

Hello Sugumaran,
Thanks for your message.

I ended up with v57a of MIAB installed on Ubuntu 18.04.

I don’t care about MIAB version being not the latest one. Though I am eager to have the latest version, of course! But I am happy with my first email server to be up and running!

Ubuntu 18.04, to the contrary, is a point of concern. It’s approaching the End Of Life point. No reason for panic though, I believe. I hope nothing bad gonna happen in the nearest months. And then VPSmalaysia will probably start offering 22.04

As for VPSmalaysia in general, they make a good impression. Of course my experience with them is limited to less than 10 days, but at least their customer support is very responsive. And no chatbots! Real humans only!

Anyway, my web server is running and is able to send and receive email. So problems still remain. I need to thing them over and if I fail to find a solution myself, I will open a new topic in this forum.

I appreciate the help from MIAB community and I am very grateful to everyone who responded.

Best regards,


I believe your download is slow because your distance from the server :slight_smile:
I use and since they have servers near to me.
While may be very near for me (and download is super fast)
it may be far for you depending your physical location.

Where you located? Near Malaysia or far away?

Hello Sugumaran,

I live far away from Malaysia, in Eastern Europe. My choice was based on reviews of some people on this forum, who praised VPSmalaysia as a reliable hoster for MIAB. Also, it proved to be inexpensive and having a good customer support. So I don’t regret my choice!

But how is it related to download/installation speed? I did not upload any files from my desktop… Instead the installed program downloaded all the components of MIAB from any remote repository. Which location does not depend, I believe, on my own location…


1 Like


Yes, I agree with you VPSmalaysia is a good choice and is also inexpensive and has good customer support.

I like the dual stack, meaning, they support both IPv4 and IPv6.

I also like the fact they accept payments using Bitcoin.

I could be wrong about the download/installation speed though as I am not a network expert :slight_smile:

Your distance from the server is the first thing that comes to everybody’s mind when you see that download is soooo slooow…

But this case is perhaps about a wrong choice of repository location…

Anyway, a MIAB user wishing to install MIAB in VPSmalaysia cloud shall be aware of the problem and be prepared to wait for a long time.

Be prepared and be patient! Two very old and yet very correct principles…


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.