Installation issues (Ubuntu 18.04)

I have tried very hard to avoid posting but I just don’t seem to be getting anywhere with installing MIAB on my new Ubuntu machine (from System76).

I am trying to set this up at my house where I have business class internet (fixed IPs) from Comcast. I have a pfSense firewall/router after the Comcast modem and before my System76 machine. pfSense seems to be set up correctly (it works as intended for the other servers at my house); that is, ports 80, 443, 25, 587, 143, 110, 465, 995, 993 for are all port forwarded to

From Terminal
:~$ sudo mailinabox
Primary Hostname:
Public IP Address:
Public IPv6 Address: 2603:3023:30e:a7f0:9877:b43e:58a9:7c47
Private IP Address:
Mail-in-a-Box Version: v0.43

Updating system packages…
Installing system packages…
Initializing system random number generator…

And then it stops. Back to the prompt.

Not sure where that IPv6 address is coming from. The network settings say 2603:3023:30e:a7f0:4a9:c3ae:e44f:bc1 instead. WhatIsMyIP? says it is 2603:3023:30e:a7f0:9877:b43e:58a9:7c47 though.

I am using external DNS and I believe it is correct.
I believe I have UFW set up correctly.
:~$ sudo ufw status numbered
Status: active

 To                         Action      From
 --                         ------      ----

[ 1] 443/tcp ALLOW IN Anywhere
[ 2] Anywhere ALLOW IN [my personal machine on same network ]
[ 3] 53 ALLOW IN Anywhere
[ 4] 25/tcp ALLOW IN Anywhere
[ 5] 587 ALLOW IN Anywhere
[ 6] 993 ALLOW IN Anywhere
[ 7] 995 ALLOW IN Anywhere
[ 8] 4190/tcp ALLOW IN Anywhere
[ 9] 80 ALLOW IN Anywhere
[10] Anywhere ALLOW IN [IP of my pfSense]
[11] Anywhere ALLOW IN nn.nn.nn.nn/28 [machines in my rack at datacenter]
[12] 22/tcp ALLOW IN Anywhere
[13] 443/tcp (v6) ALLOW IN Anywhere (v6)
[14] 53 (v6) ALLOW IN Anywhere (v6)
[15] 25/tcp (v6) ALLOW IN Anywhere (v6)
[16] 587 (v6) ALLOW IN Anywhere (v6)
[17] 993 (v6) ALLOW IN Anywhere (v6)
[18] 995 (v6) ALLOW IN Anywhere (v6)
[19] 4190/tcp (v6) ALLOW IN Anywhere (v6)
[20] 80 (v6) ALLOW IN Anywhere (v6)
[21] 22/tcp (v6) ALLOW IN Anywhere (v6)

Can’t connect to or /mail nor localhost/admin or /mail.

Any guidance would be very appreciated. I am so frustrated.
I process more than a million emails a year on my very old Mac email server just fine. But this Ubuntu thing is just eluding me.


canyouseeme port checker says ports 80 and 25 are closed.
Doesn’t make sense to me, but I accept it. Can’t determine where the issue is though.
pfSense can see from wan side and lan side and lan can see as well.

Software Update app says everything is up-to-date for Ubuntu on the machine.

Hello Keith,

I wish that I could offer some assistance, but you are attempting to install MiaB in a very unique (for this project) environment.

There will be a few potential folks in this forum who may be able to assist.

It is not a Ubuntu thing … it is a network thing based on the fact that you are installing behind a pfSense firewall/router at home, rather than on a VPS in a data center.

Can you post a screencap of the MiaB status page? It may be helpful.

You are missing port 53, but that will not cause this:

I can’t show the status page because I can’t get to it.

And why is my network a problem?
The two other servers in my house aren’t having issues; I have business class internet. The 19 servers behind my pfSense firewall in my datacenter rack don’t have any issues. None of them are Ubuntu or MiaB; so I suppose you are right cuz it seems to be one of those two reasons.

It seems to me that MiaB is not completing its install process. Something is causing it to end early.
I will try again but I will add port 53 first.



Uhmm wait. You are installing this on a laptop or desktop machine?

Exactly WHICH version of Ubuntu did you install? Be VERY specific.

You also claim that install fails, but yet UFW is working?

So answer me this … is there a /home/user-data/ directory?

This is on a Meerkat machine from System76 running Ubuntu 18.04 LTS.
:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.3 LTS
Release: 18.04
Codename: bionic

UFW did not get enabled by the MiaB installer. All the settings that I noted before were done by me.

:/home/user-data$ ls -l
total 16
-rw-r–r-- 1 user-data user-data 8980 Apr 16 2018 examples.desktop
-rw-r–r-- 1 user-data user-data 3 Nov 2 02:33 mailinabox.version
:/home/user-data$ sudo nano mailinabox.version

The November 2nd date tells you how long I have been trying to avoid bothering this list!


It is no bother, that is why this forum is here!

You didn’t answer my question though … which ISO did you install the OS from? or was this pre-installed? I have no idea what a ‘Meerkat’ machine is, so you need to answer what I ask. Is this a desktop, laptop, or rack server?

Go to the home directory of the user that you installed MaiB as and then
cd mailinabox
cd management

Oh, and don’t do this! MiaB will install everything that it needs.

:~/mailinabox/management$ ./
bash: ./ /usr/local/lib/mailinabox/env/bin/python: bad interpreter: No such file or directory

Would seem to suggest something is missing…

The Meerkat comes with one of these three operating systems
Pop!_OS 19.10 (64-bit), Pop!_OS 18.04 LTS (64-bit), or Ubuntu 18.04 LTS (64-bit)

I picked Ubuntu because I thought that is what MiaB required.


Which edition?

I’ll ask for the last time … is this a server or a desktop/laptop? Do you have a graphical display that is more than a mere terminal?

Ok, I have now had the time to Google what you have bought. As purchased it is not suitable for MiaB. Your “Meerkat” does not run the Ubuntu 18.04 Server edition, but rather the desktop edition.

You need to reinstall the OS with this image:

or seriously consider getting a machine that is more suitable for the job. i.e. less fancy.

MiaB is not properly installing because of the graphics related stuff (amongst other things) in the desktop edition of Ubuntu.

This information is not so clear on the MiaB install page as the installation instructions refer to installation on a VPS, not a physical machine such as the “Meerkat”.

Yes I have a desktop.

That really matters? I had MiaB mostly working on the machine during the summer (mail worked in my email client, web mail worked but only with IPv4). I started over due to all my efforts for bringing IPv6 into my network caused a bunch of issues; now they seem to be all worked out.


OK. Pretty disappointed about this.
I will reinstall the OS but with the server version. I don’t need the desktop.

I was apparently misunderstanding the difference; thought the desktop was Ubuntu plus the graphics stuff. But I do wonder how it was working during the summer.

Will post back after I find time to start over again.


@Keith_Rettig I don’t think the desktop/server different should really make a difference. It looks like the Mail-in-a-Box setup isn’t finishing. If it’s ending after “Initializing system random number generator…” then it hasn’t done almost any of the setup yet. Something at that stage is failing. Your best bet is to try to figure out which command is failing by looking through the setup source code and seeing what’s after that message. Usually hard failures signal easy problems.


Working from Josh’s comment can you check to see if this file exists???


A ray of hope shines again. :slight_smile:
Suggestion as to where the setup source code is located?


You are failing around line 227

:~/mailinabox/management$ cd /root/.ssh/
bash: cd: /root/.ssh/: Permission denied


sudo su

Drop to root then check. But that may not be an accurate check - if it is there. If it is not, you know that you failed at line 221 or 227

echo Initializing system random number generator...

dd if=/dev/random of=/dev/urandom bs=1 count=32 2> /dev/null

# This is supposedly sufficient. But because we're not sure if hardware entropy

# is really any good on virtualized systems, we'll also seed from Ubuntu's

# pollinate servers:

pollinate -q -r

Also, you are about at max replies for the first day in this forum. :frowning: So be advised that you may not be able to reply any more today soon.