Install works on Ubuntu 18.04 64 Bit but fails with Ubuntu 22.04 64 Bit

With the same DNS configuration, same hostname, same VPS provider (racknerd 2GB 2 cpu vps), I get an error with 22 but it works with 18. (I tried 20, but the install gave me a message that miab only works with 16, 18, or 22).
The error comes after I type the password:

Installing nsd (DNS server)…

Generating DNSSEC signing keys…

Installing Postfix (SMTP server)…

mv: cannot stat ‘/var/lib/postgrey/*’: No such file or directory

Installing Dovecot (IMAP server)…

Creating new user database: /home/user-data/mail/users.sqlite

Installing OpenDKIM/OpenDMARC…

Installing SpamAssassin…

Installing Nginx (web server)…

Installing Roundcube (webmail)…

Installing Nextcloud (contacts/calendar)…

Upgrading to Nextcloud version 26.0.12

Nextcloud is already latest version

photos 2.2.0 disabled

dashboard 7.6.0 disabled

activity 2.18.0 disabled

Installing Z-Push (Exchange/ActiveSync server)…

Installing Mail-in-a-Box system management daemon…

Installing Munin (system monitoring)…

Command ‘[’/usr/sbin/service’, ‘nsd’, ‘restart’]’ returned non-zero exit status 1.web updated

Okay. I’m about to set up wes@******.com for you. This account will also

have access to the box’s control panel.



<!doctype html>

500 Internal Server Error

Internal Server Error

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.


On ubuntu 18, it gets past this point and completes. I tested everything and things work great, but of course, I’d rather not be on 18 as I see a message about it being unsupported soon. Any ideas?
Thank you.

MiaB requires a vanilla Ubuntu. In the past there were some issues/incompatibility with custom Ubuntu images VPS provider use. No experience with this provider but it might one explanation.

This might also point at issues. Check out sudo journalctl -u nsd

Thanks for the replies. Currently, I can’t test /troubleshoot the broken one, because I have only one VPS available and it’s currently set to the 18.04 ubuntu because that’s the one that works and I’m excited to set it up and get going! I’ll try again some time later if I ever tear this one down.

Are you running the latest version of MiaB? TBH, I’m surprised it works so well on 18.04 because it was designed specifically for 22.04.

That being said, 18.04 reached end-of-life last month, so if you’re serious about using MiaB as your emIl solution, my advice would be to focus on resolving the problem you’re having with 22.04 rather than using something that’s no longer supported.

The latest MIAB does not work on Ubuntu 18.
People seem to just write on this forum everything that pops into their mind.
The latest MIAB works out of the box on any Ubuntu 22 so there seems to be some hallucination going on. There are instructions how to move the box from 18 to 22.
@wesyah234 Are you moving the box from 18 or you are just tryong to make a fresh install?
If you are fresh installing check if the 22 is minimal version. That might be a problem or maybe it is a arm64 Ubuntu?

Follow the instructions precisely don’t just hit enter randomly. Just kidding. :slight_smile:

The reason I’m trying 18 is because when I tried the miab install on a ubuntu 20 box (*after my problems with 22), it reported back to me that miab only works on 16, 18, or 22 (which admittedly, I thought was odd, but I’m new to this, so I just went ahead and tried 18 for now)…

I’m doing a fresh install.

I’ll definitely find some time to attempt 22 again. Totally understand the cons of continuing on 18!

Do not continue on 18. It is just waste of time. Ubuntu 22.04 x64 (server edition)
This is what is supported. Hello!

1 Like

Hi. People have had trouble with hoster provided Ubuntu images in the past. I know nothing about your provider but some providers are known to tweak the networking on their “standard” images. Is it possible for you to start with an image you’ve downloaded from

looks like it might be possible:

any ideas how to fix this? Thanks!

There seems to be an issue with ipv6. There are some posts here on the forum to completely disable the ipv6 stack. Maybe that helps. (e.g. sudo sysctl -w net.ipv6.conf.all.autoconf=0)
Alternatively, the solution described here might help.

Which again could be due to custom network settings or the network infrastructure of some VPS providers, because in my experience there is usually no need to disable IPv6 at the OS level, meaning if you don’t want to use IPv6 with a standard Ubuntu ISO or cloud image, just don’t connect the VM/VPS to an IPv6 network and it should work just fine.

So, I had to move my vps to another data center with RackNerd to have ipv6 support, then after moving it, they give me this long explanation about things I will have to do to deal with ipv6 on ubuntu 22… is all this necessary?

I guess my next attempt would be one other suggestion above to have my provider install a ubuntu iso directly from ubuntu… … or attempt the below steps…

We have assigned IPv6 address to your server successfully now.

IPv6 address - 2607:f…

Configuring IPv6 on Ubuntu 22.04 systems is a bit different compared to previous versions of Ubuntu. You can run the below 3 commands in SSH in order to bind your IPv6 address to your server.

Note: Keep in mind that these commands must be rerun after every system reboot to keep IPv6 functional. To avoid manual repetition, you could set these as startup commands using utilities like systemd or rc.local.

The 3 commands are as follows:
ip -6 addr add IPv6/64 dev “interface name”
ip -6 route add GW dev “interface name”
ip -6 route add default via GW dev “interface name”

IMPORTANT: In the above commands, replace “IPv6” with your server’s IPv6 address and “GW” with the gateway address: 2607:f130:0000:0103:0000:0000:0000:0001

Note: Lastly, also ensure that your /etc/sysctl.conf file does not have any values in place that might be disabling IPv6 connectivity. If it does, be sure to comment those out and refresh your settings afterwards by using “sysctl -p” or by rebooting your VPS.

Thank You,

it sounds like it is… why are you not trusting their information? Isn’t this your providers instructions?

Would “rebuiliding your virual machine” in the data center that supports IPv6 make this happen automatically?

That might be the question I ask them… not sure how far along you are with your current virtual machine but I’m guessing if you want IPv6 you can always have them help you though this a bit more?

if you need it to be easier maybe select a different VPS provider

1 Like

It’s not that I don’t trust the info, I just don’t understand enough about whether ipv6 is required by miab or not. I just don’t know if I’m going to do all these extra steps on every reboot and to what end? … I just don’t see much in the miab documentation about how to handle this v4 vs v6 stuff.

Also, these steps they sent me were after I moved to the data center that “supports ipv6”… and I tried the install as is before doing anything specific to activate the ipv6 addr on the server…

the the verbiage about adding this to /etc/rc.local, you would literally just create this file:

vim /etc/rc.local

add these commands to that file

p -6 addr add IPv6/64 dev “interface name”
ip -6 route add GW dev “interface name”
ip -6 route add default via GW dev “interface name”

IMPORTANT: In the above commands, replace “IPv6” with your server’s IPv6 address and “GW” with the gateway address: 2607:f130:0000:0103:0000:0000:0000:0001

reboot the box and see if the IPv6 address is reapplied after the box reboots.

personally I like this guide:

You’re absolutely right! It isn’t actually that much work. I went ahead and added those 3 lines to /etc/rc.local and also found some lines that seemingly disabled ipv6 in /etc/sysctl.conf and commented them out, and it seems to have done the trick. The box reboots with it’s assigned ipv6 address… and the best part, is that the miab install now works!

Thanks to everyone for the hand holding!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.