I can send email perfectly but can't receive mail

I am using MIAB with 3 domains. The primary works fine, the second works fine too and the third is not able to receive emails

I get this message after a few days:

The MX host does not match any MX allowed by the STS policy

I am using external DNS for the 2nd and 3rd domain

I went over the DNS settings and deleted and re-entered them over and over again on the domain registrar

I also tried to delete the MIAB mail folder in the ‘mailbox’ dir and it keeps reappearing

I tried to delete the backup folder too and the domain with the user inside keeps reappearing

how can I wipe out the domain and every single settings referring to it totally and definitively ?

I want to remove this domain from every file on the server

we can receive mail from protonmail.com but not from gmail

Did you delete all email addresses for the domain through the MiaB dashboard?

Is it possible there was DNS caching issue?

This error usually means that the MX in your DNS is not the same as in the STS policy (which is created by MIAB automatically)

You mentioned you’re using external DNS, are the MX records pointing to the same host name as the box? If there is a mismatch, the STS policy will prevent it from delivering as expected as the STS policy makes sure the MX on the policy and the DNS match.

I flushed the DNS cache and it’s working now!!! thank you!!!

still when I send it, the mail arrives at google right away, when I receive it from google it takes 5 minutes and sometimes longer

1 Like

That’s called grey listing. It saves a lot of spam. Initial send email wil be rejected and have to be sent again after about 90 seconds.

Most mail servers have a 5 minutes retry time

The greylisting tool, postgrey, stores server information for servers that pass the greylisting “test” so that future emails from the same address (or server, I forget) will go through immediately.