How to set an A record?

I am setting an A record under System in “Set custom DNS records”. Then going and installing a fresh wordpress or ghost blog droplet install from DO’s marketplace. However, once it’s installed I’m getting “404 Not Found nginx”. I imagine that both wordpress and ghost would not both have the same errors, and that therefore the issue must be me. Is there something to do with Mail-in-a-box that I am missing? Thank you!

If you check the domain at, does it list the IP address you are expecting for the record?

Yes, I see the expected IP address. However, when I go to the domain in the browser I am still directed to MIAB’s static page, which is not that IP address.

Likely your caching DNS server needs to time out.

You’ll need to check the record and see what remains on the TTL locally.

If you are using Linux, dig is installed by default. You can install dig in MacOS, and I think in Windows use nslookup, though I’m not sure what command options.

Oh, and of course try clearing the browser cache.

Try flushing the DNS cache on your local computer. How? Google is your friend.

Thanks all for these replies. It was helpful to pinpoint the issue. I found there is an unknown issue in my network. If I access the site from VPN it now works as expected.

1 Like

The default TTL for all MiaB records is 86400. You likely have a caching DNS server (e.g., ISP provided DNS server) that is still on the TTL. Using the VPN you switched to a different caching server that hadn’t previously looked up the record.

You also could switch your network to a different caching server, such as CouldFlare ( and and enjoy the same results.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.