How to install older version

Hello Josh,

Lets say I am a bit of a lamer :slight_smile:

But I am very happy using the previous versions of MIAB - Installed it last year (August) and it just keeps working.

Now I need to move the machine and that’s why I have to install it again.

After 8 installs lot of issues are still an obstacle while trying to
install the latest release on VPS (OpenVZ). I am not sure what is
relevant, but obvious errors can be easily experienced with the current
install methods:)

  1. “curl -s | sudo bash” is not
    capable of making the complete install anymore - apparently well known
    problem is “sha1sum: WARNING: 1 computed checksum did NOT match”

  2. Using “git clone and
    bash setup/” seem to go quite further and actually finalizing
    the installation, but with lots of consecutive errors ( in order of
    appearance) :

  • swapon: /swapfile: swapon failed: Operation not permitted

ERROR: Swap allocation failed

  • Installing Munin (system monitoring)…

No module named ‘_cffi_backend’

500 Internal Server Error

Internal Server Error

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.

Traceback (most recent call last):

File “management/”, line 803, in


File “management/”, line 446, in provision_certificates_cmdline

status = provision_certificates(env, 

agree_to_tos_url=agree_to_tos_url, logger=my_logger,

File “management/”, line 266, in provision_certificates

import acme.messages

File “/usr/local/lib/python3.4/dist-packages/acme/”, line 5, in

from acme import challenges

File “/usr/local/lib/python3.4/dist-packages/acme/”, line 9, in

import OpenSSL

File “/usr/local/lib/python3.4/dist-packages/OpenSSL/”, line 8, in

from OpenSSL import crypto, SSL

File “/usr/local/lib/python3.4/dist-packages/OpenSSL/”, line 12, in

from cryptography import x509

File “/usr/local/lib/python3.4/dist-packages/cryptography/x509/”, line 7, in

from cryptography.x509 import certificate_transparency

ImportError: cannot import name ‘certificate_transparency’

Your Mail-in-a-Box is running.

Please log in to the control panel for further instructions at:

Traceback (most recent call last):

File “management/”, line 993, in

ssl_certificates = get_ssl_certificates(env)

File “/root/mailinabox/management/”, line 17, in get_ssl_certificates

from cryptography.x509 import Certificate

File “/usr/local/lib/python3.4/dist-packages/cryptography/x509/”, line 8, in

from cryptography.x509.base import (

File “/usr/local/lib/python3.4/dist-packages/cryptography/x509/”, line 16, in

from cryptography.x509.extensions import Extension, ExtensionType

File “/usr/local/lib/python3.4/dist-packages/cryptography/x509/”, line 18, in

from cryptography.hazmat.primitives import constant_time, serialization

File “/usr/local/lib/python3.4/dist-packages/cryptography/hazmat/primitives/”, line 9, in

from cryptography.hazmat.bindings._constant_time import lib

ImportError: No module named ‘_cffi_backend’

You will be alerted that the website has an invalid certificate. …"

  • In the mail log can be found:

Couldn’t unlink “var/run/” [Permission denied]

Couldn’t unlink “var/run/” [Permission denied]

  • … and lots of other errors

  • The machine can not resolve domains after the installation so it needs manual edits.

With that being said - I think it is much easier if there is a simple way how to install lets say version 0.19A or 0.21.

Can you help, please?

Download and then edit the file so the bash variable TAG is equal to 0.24 or something.

then run the setup. make sure to remove the cloned repo first as that will conflict with the 0.24 install.

1 Like

WOW That was quite instant! Even the premium Microsoft support is not that adequate!

That worked perfectly:

0.24 I think gave me the same problems… or similar - I did not explore more.

0.23 Gave me similar initial error, but after second run of the same file on top of the installation it WORKS :smiley:

You made my night happy!

1 Like

I forgot to mention - I did a clean install as it was much easier … You are right - it conflicts the other software versions when I tried to just install it with older tag…

Thank you!

1 Like

glad it worked for you, once installed, updating to the latest version works fine.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.