How do I get rid of "Something went wrong sorry" and get Custom DNS back? [RESOLVED]

Hi,

I have installed numerous MiAB’s over the years and they have always worked well. But in the last year or so the insistent “Something went wrong, Sorry!” message keeps coming up when I go to the Custom DNS page. I modify them manually in the DNS .yml file but they don’t seem to “stick.” The DNS page comes up with all the text but … the records! And of course trying to add one just gives that error. I don’t understand why it can’t just tell you what’s wrong.

I have installed fresh MiAB’s three times in the last month and this has happened on two (all but the newest one.) The status checks always work fine, and I can create mail users, but it just doesn’t like the Custom DNS page. Is there any way to fix this? It’s been going on for years on different VPS providers. Confusing.

Thanks,
Steve

Have you verified that custom.yaml only has domains currently hosted by MiaB?

No I haven’t, and it’s quite possible it doesn’t. I’ll take a look.

WOW! I just removed two entries in custom.yaml, yes only two old entries not hosted there, and now the page loads normally! Amazing! Well you were dead on. Thanks so much for your help!

Regards,
Steve

1 Like