Google Gmail/Gsuite SPF fails?

Hi all, just wondering if anyone else is suddenly seeing SPF or similar fails from Google Gmail users?

I am running MIAB with everything updated, no custom SPF so nothing changed on that front. Formerly worked fine but now seeing multiple rejections/misclassification as spam.

Example rejection from a group address (but not limited to this, also users) that previously worked fine:

Your email to group was rejected due to spam classification. To address this issue: * Contact the owner of the group, who can choose to enable message moderation instead of bouncing these emails. * Set up SPF records for your sending domain if you have not done so already. Instructions for both steps can be found here:

DNS is hosted on MAIB.


I had the same thing, reason being that my internet service provider (earthlink) forces me to use their smtp relay services. In this particular setup you need a custom DNS configuration to include the provider relay IPs in the SPF setting.

Example; ( includes earthlink smtp relays)

your.domain txt v=spf1 ipv4: -all

Thanks Volkert!

In this case I’m only using the MAIB as smtp.