Godaddy and Digital Ocean DNS

I created a brand new droplet at Digital Ocean, then went to Godaddy to the hosts section and added the hosts: to Droplet IP address to Droplet IP address

This is there name for Glue Records

Next I go to the Name Servers section and put in the two NS and save and I get back from GoDaddy an email that says "We couldn’t complete your domain changes.

The modifications you requested for have failed.

This is the error we received: Object does not exist "

So obviously on the MIAB - I’m getting the message:
Nameserver glue records are incorrect. The and nameservers must be configured at your domain name registrar as having the IP address [DROPLET IP ADDRESS] . They currently report addresses of [Not Set]/[Not Set]. It may take several hours for public DNS to update after a change.

I’m scratching my head here. Anyone seen this issue with Godaddy?

Yes, GoDaddy sucks!

The last time I set Glue records on GoDaddy it took a few hours before they actually set them. The name server change will fail if the glue records are not actually already set.

I recently helped someone who tried for 4 days with no luck! He transferred his domain to a different registrar.

GoDaddy is probably the worst registrar and web host out there. The only thing that they excel at is marketing.

So, the answer here is one of two things. Either time, or transfer your domain elsewhere. The one saving grace is that GoDaddy is one of the few registrars who allow you to complete a domain transfer within your GD account, so 3 times out of 4 you can transfer to a new registrar in less than an hour. Of course, that is not perfect either as ONLY 3 of my last 4 transfers out of GD were quick.

Good luck!

So Godaddy goes “well is not resolving” - well you see the host name is there - but the NS needs to be put there. “they dont exist so you can put it there”

u need to take this troubleshoot to godaddy.

Sorry, you completely lost me here.

Sorry, you completely lost me here.
She (godaddy support) said that since the name servers didnt resolve yet she couldn’t set them.

I bought another domain name on ghandi, followed the steps, worked perfect, its totally godaddy and not resolving DNS.

1 Like

What a shame you had to do that, but congrats that it all works!

Now, for bonus points, set up Secondary DNS with Gandi’s ns6 since they offer it for free! :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.