Gmail won't accept mail from my M-I-A-B

I recently setup a MIAB server. I tried sending an email to a gmail address today and it got returned. Here is what I got back.

“host[] said:
550-5.7.25 [] The IP address sending this message does not have
a 550-5.7.25 PTR record setup, or the corresponding forward DNS entry does
not 550-5.7.25 point to the sending IP. As a policy, Gmail does not accept
messages 550-5.7.25 from IPs with missing PTR records.”

What is a PTR record and how do i set that up in MIAB?

Thank you.


A PTR record is also known as “Reverse DNS” and it is set up by the owner of the IP address used. Who is hosting your MiaB installation?

I am using a VPS hosted by DigitalOcean.

So i just did a reverse lookup with MXtoolbox ( and they reported that my PTR is setup correctly. So I tried to send another email to gmail and it got bounced back but with a different message:

“host[] said:
550-5.7.1 [ 12] Our system has detected that this message
is 550-5.7.1 likely unsolicited mail. To reduce the amount of spam sent to
Gmail, 550-5.7.1 this message has been blocked. Please visit 550-5.7.1
Why has Gmail blocked my messages? - Gmail Help 550 5.7.1 for
more information.”

What more can I do to prevent Gmail from blocking my emails?

After I updated my post I click on the gmail help page and read through it. I followed their instructions and added a google verification txt record to my dns settings. Now when i send my gmail account an email it gets bounced back with yet another message:

“host[] said:
550-5.7.26 The MAIL FROM domain [] has an SPF record with a
hard 550-5.7.26 fail policy (-all) but it fails to pass SPF checks with the
ip: 550-5.7.26 []. To best protect our users from spam and
phishing, 550-5.7.26 the message has been blocked.”

Looks like I’m in for a fun game of whack a mole.

Gmail can be a pain but the standard MIAB setup has all the normal SPF etc records - it’s only the reverse DNS stuff that is outside MIABs control. If nothing has been changed, I’d expect the SPF, STS, DMARK, and DKIM to be correct.

I found it helpful to send to my box from google! Seems they recognised my box after that.

Ahh … I see you’re using Digital Ocean - they have a reputation for being blocked by the big email handlers, due to hosting lots of spammers. No much you can do but move to another provider :frowning:

If your box has IPv6, the RDNS for that is separate from from IPv4 RDNS. IPv4 RDNS is controlled by your provider - just ask them to set it, which you’ve done. But IPv6 RDNS is controlled by your box - you have to ask your provider to “delegate” IPv6 reverse DNS to your box, and then setup your box to provide suitable replies. There are details about setting up suitable zone files on this forum.