Gmail marking emails as spam


I’m getting all my emails marked as spam by Gmail.

I’ve tried to to move the box to a different region, it’s now in Amsterdam.

Have checked below links and my IP address is not among the listed ones:

Also the headers look okay to me.

Received: from ( [])
by with ESMTPS id fv4si23342957wjb.123.2016.
(version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128);
Sat, 27 Feb 2016 13:10:44 -0800 (PST)
Received-SPF: pass ( domain of designates as permitted sender) client-ip=;
spf=pass ( domain of designates as permitted sender);
dmarc=pass (p=QUARANTINE dis=NONE)
Received: from authenticated-user ( [])
(using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits))
(No client certificate requested)
by (Postfix) with ESMTPSA id 38C6B143A1A
for; Sat, 27 Feb 2016 22:10:44 +0100 (CET)
DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple;;
s=mail; t=1456607444;

I’ve also tried to sign up with Google Postmaster tools but are still marked as spam.

Can you please advise?


Would it help to move the server to any other VPS provider?


I’ve had the same problem about a month and a half ago. I didn’t switch the VPS provider, nor the zone. All I did was to add the _dmarc. and mail._domainkey TXT entries into the DNS provider. And about two weeks later the people which use the email service I provide [about 5 of them] stopped complaining their emails don’t reach the desired inboxes.

I really hope this is of use to you!


Thanks for your answer.

Is this something that needs to be done in the Mail-In-a-Box setup?

Since I’m using MIB as DNS nameservers - as advised in the setup instructions- I can’t add any TXT records in my Namecheap domain config anymore.


Not really an expert here :), but if no one gives you a better answer you could try adding the records anywhere you can. I am using DigitalOcean for my MiaB and I added the DNS records in the DO interface.

This indicates everything is set up correctly. There is no need to worry about adding DNS records.

Hi @JoshData

If the DNS setup is correct, do you have any idea as to what’s going on?

Is it possible I might have gotten another blacklisted IP from DigitalOcean despite all the abovementioned links saying it is not?


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.