Gandi (

Hello everyone,

I’ve successfully setup my MIAB, and it’s working well. However, I wanted to use a secondary DNS provider. As I use as a Domain registrar, I thought I would use – First I add this to MIAB → Custom DNS → Secondary nameserver →

Then at Gandi/control panel/2nd name server →

However, it never “takes” always reverts back to<> …

I have tried several times and even reached out to Gandi who waffled the following:

Please ensure that the necessary NS records are present in your zone, namely:

Additionally, please ensure that zone transfers are authorized according to our documentation found at:

The Bind statement for this is:
allow-transfer {; 2001:4b98:d:1::40; }

Furthermore, please remember to increment the zone’s serial number and notify any changes with:
also-notify {; 2001:4b98:d:1::40; }

I’m baffled, because from what I understand it should be simple as my updates I’ve carried out.

I then tried which actually had been working well. However today I check my MIAB status and it’s showing Secondary nameserver is not configured correctly. (It resolved this domain as [timeout]. It should be .)

I can’t even log into my account at puck. It’s down perhaps?

I’m looking for something stable, and don’t even mind paying for a secondary DNS provider?

Anyone ?


I had the same issues with and their support always claimed the issue was on my end with the exact same message. I don’t know enough of this to understand if MiaB is compatible with Gandi ootb. As a result I moved to which seems down now…

We are both in an identical situation

@eXTric – I’m glad it’s not just me then. So, I’m on the lookout for further options.

Puck might just be a glitch at the moment, but I’d rather have another option even if it’s a couple of “quid” a month or something…

Perhaps you already have this, but it’s not shown in your message, but the Secondary nameserver setting in you MIAB should be: xfr: xfr:2001:4b98:d:1::40
The xfr entries tell MIAB that gandi is allowed to get the nameserver information.



I never knew that!! THANK YOU!. I’ll give that a go.

After following @KiekerJan post, all is working perfectly. If only I knew a few weeks back! I now have a perfectly working and configured MIAB install. Thank you.

Thanks for the suggested fix. It seems to work now.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.