Filter Emails From an Alias

Hi Guys,

Can anyone help me with filtering an email from an alias. The Alias name/address shows correctly in the To: field, but in the detailed view you can see that the email was sent internally to the parent not the alias (as expected).

What field would I have to identify to capture the alias information in the filter.

I hope this makes sense to someone. Fingers crossed

If I understand what you mean, look carefully through the full header. The alias may be among the very first added by MiaB, so toward the bottom of the headers.

Thanks for replying I appreciate it.

I see it there, its way down under the second ‘Receive: From’ heading and this is a bit of a noob email related question rather than a system q… but how do I refer to that field specifically from the drop boxes provided in the filter options? I’ve been through almost all of them with no success.

Any help gratefully received

Which drop-down boxes?

What do you mean that you are receiving ‘from’ an alias? I may have misunderstood that you are receiving ‘to’ an alias (e.g., -> as configured in the MiaB admin panel “alias” configuration page.

  • I have a bucket ‘User’ with access to a mailbox

  • I have then set up 4 ‘Aliases’ forwarding to that bucket

When I send an email to one of those aliases from say - Gmail, they arrive in the bucket mailbox addressed to the alias (as expected) but they have been forwarded there by virtue of the Alias association with the bucket.

Even though the email To: field says alias@ whatever, if you open the all headers info you can see that it was actually sent to bucket@ whatever, and the actual alias field occurs further down the headers list (received: from)

I suppose I’m just looking at how to correctly identify that field, so that I can filter these emails from system aliases.

I appreciate you helping out.

For the filters page of Roundcube, I suspect using the “To” option should process as you are desiring. You also can optionally create a filter from the menu in view email pane.

1 Like


Thank you very much for your help. I feel a bit dumb now, but it was because I hadn’t selected the Roundcube filter set (having no idea what it was)

I created filters from the emails and added a new filter set. When I selected the roundcube set it worke perfectly.

Thx again for pointing me at the right solution, much appreciated.