Experimental version with quotas for testing


#1

I have a version of MiaB v0.40 running with quotas and would like to see some testing and feedback. This version should be considered experimental and not installed on production servers unless you really know what you are doing and can restore the standard version quickly. That said, I am using it on two servers without any issues at present.

The repository and installation details can be found at:

Bugs should be reported on Github not on this forum.

Thanks


#2

i plan to look install and test later … but one question.

How do I comment on git-hub? There is no Issues tab …

Yes, I am unfamiliar with Git-Hub, so help me out here. :slight_smile:


#3

Sorry, I had not enabled the issues module. Thanks for pointing that out. You should find it if you go there now.


#4

I have taken my first VPS down that was running 14.04, and have a fresh instance of 18.04 ready for an install with quotas.
Got advice how to do a fresh install? I am not git literate. I know how to download the zip of the project.
I installed 0.30 and 0.40 using the curl line in the mailinabox.email site.
Exactly what do I do for this beta? Don’t skip anything. I want to help you move forward.

Git is saying the last commit can’t be retrieved?

Thanks

Dennis


#5

I updated the instructions on the GitHub project page to be more explicit. Go to https://github.com/jrsupplee/mailinabox and follow the directions there for a new installation.

Not sure what the git error was you had, if you can post more information or a screenshot I might be able to help.

Let me know if there are any issues.

John


#6

This should be in it’s own thread I think unless you are specifically talking about this specific unsupported version of MIAB :slight_smile:


#7

Followed your instructions and installed without issues.
I’ll leave it running until you have further changes.

I dumped my running 0.40 instance by mistake. Stupid mistake on my part. I got to experience bringing it back up.

For others benefit, you have to turn off DNSSEC at the registrar, turn it back on with the new data.

Looks good.

Dennis


#8

Works really well! Nice!


#9

I have experienced maybe an anomaly.

This morning I checked the status page and it indicated updates had been applied and I should click reboot.

I did that and now Ubuntu is at 18.04.2.

Running on Linode. Their 18.04 image yields 18.04.1.

Similar experiences?

I did NOT do a apt-get dist-upgrade.

Dennis


#10

You should be fine. :slight_smile:

Ubuntu does that…


#11

Thanks for testing @dwomack. I am running it on two production servers without any problems. Let me know if you face any problems.

Have you tried setting quotas? Try setting a quota on a test user to a a small amount (1M) and then send it a large email and see if it is rejected. Anything you can do to try to break it will be helpful.

The issue you experienced with Ubuntu upgrading is not a problem or a result running MiaB with quotas. Ubuntu 18.04 does automatic package upgrades by default (unlike 14.04).


#12

Quota worked.

I set a 1M quota and sent a much larger attachment.

Tried from two different email accounts, one being Apple. Both messages bounced with a message saying mailbox full.

Thank you for your efforts.

Dennis


#13

If you have any issues, post them here or on Github