Errors when trying to install MIAB on a local Ubuntu system

How feasible is it to get MIAB running on a local Ubuntu 14.04 system rather than on a remotely hosted one? I’m trying to install it locally, but I’ve been getting error messages. I didn’t have an SSH connection established when I ran the installer but instead I was doing it directly, and the installer reported an error because of that, but also I’m getting the following error when running the installer (I’ve replaced my domain name with a sample one, but I have mine also start with “box.” as the example does…):

IN A: Server UDP port 53 answered SERVFAIL).

… When I try to access the browser based control panel, it says “Access Error: Site or Page Not Found. Cannot open URL”, and also the SHA1 Fingerprint that the installer returned wasn’t the same as the one that the browser reported when I first tried to open the control panel url.

I’ve purchased a domain name and pointed it to my internet IP address according to the instructions, and also I’m using a business-class internet connection which should allow the use of an email server. I haven’t purchased and implemented an SSL certificate yet though, could that be relevant to my problem?

Other issues I’ve been having is that I ran the installer before setting a static IP for the computer, and now every time I try to set the static IP it always reverts to the IP that it had when I ran the installer.

How close am I to having a running installation? Do instructions exist someplace for specific issues when installing this software locally?

Thanks for your help…

The process is EXACTLY the same EXCEPT:

  1. You need to open a few ports on your firewall(unless stated in pic, ports are UDP & TCP) pointing to the internal IP Address for your box:
  2. Once the ports are open, you need to set your PTR Record to your new host:
    This is done with your ISP.
  3. The nameservers for your domain need to point to (which will point to your home IP address.)

If I missed something I will edit or make a new comment.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.