Error while running mailinabox but worked fine earler


#1

it was working fine till i try login in and i cant access my ip on my browser which worked not long after i encountered this error… this is my error please help…

Nextcloud is already latest version
Installing Z-Push (Exchange/ActiveSync server)…
Installing Mail-in-a-Box system management daemon…
Installing Munin (system monitoring)…
[Errno 40] Too many levels of symbolic links: ‘/home/user-data/ssl/ssl_certificate.pem’

500 Internal Server Error

Internal Server Error

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.


Your Mail-in-a-Box is running.

Please log in to the control panel for further instructions at:

Traceback (most recent call last):
File “management/status_checks.py”, line 986, in
tls_cert = get_domain_ssl_files(domain, ssl_certificates, env)
File “/root/mailinabox/management/ssl_certificates.py”, line 153, in get_domain_ssl_files
“certificate_object”: load_pem(load_cert_chain(ssl_certificate)[0]),
File “/root/mailinabox/management/ssl_certificates.py”, line 600, in load_cert_chain
with open(pemfile, “rb”) as f:
OSError: [Errno 40] Too many levels of symbolic links: ‘/home/user-data/ssl/ssl_certificate.pem’
https://ipaddress/admin

You will be alerted that the website has an invalid certificate. Check that
the certificate fingerprint matches:

x509: Cannot open input file /home/user-data/ssl/ssl_certificate.pem, Too many levels of symbolic links
x509: Use -help for summary.

Then you can confirm the security exception and continue.


#2

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.