Error upgrading from v0.25 to v0.26

I’m running into an error upgrading from v0.25 to v0.26

I checked out v0.26 from git, ran ‘setup/’ and got the following.

Installing Z-Push (Exchange/ActiveSync server)…
Installing Mail-in-a-Box system management daemon…
Installing Munin (system monitoring)…
Incorrect username or password
Incorrect username or password
No domains hosted on this box need a new TLS certificate at this time.
The management daemon refused access. The API key file may be out of sync. Try ‘service mailinabox restart’.

Your Mail-in-a-Box is running.

Please log in to the control panel for further instructions at:

sudo service mailinabox restart

  • Restarting Mail-in-a-Box Management Daemon mailinabox
    start-stop-daemon: warning: failed to kill 12714: No such process

ps aux
root 1591 0.0 4.1 344172 42036 ? S 11:27 0:02 python /home/admin/mailinabox/management/

for good measure I tried I ran sudo mailinabox and then curl -s | sudo bash and got the same results.

Thank you for your help,

1 Like

Same problem here - except I’m totally hosed and can’t even get the admin console to come up. I had also tried deleting the SSL directory before install / upgrade. Please help.

I’ve posted a new release. I would try upgrading to v0.26b and, if that doesn’t help, try rebooting the server. Then post here again and let me know what’s happening.


I get the same error that I got before when running the 0.26b. I don’t believe rebooting the server is going to help the issue, but I did a reboot. The admin panel says “You are running version v0.26b.”, but it looks like the install is not finishing. The local.conf in nginx/conf is not being updated, but the ssl config was, I don’t know if that give you an idea of where it might be stopping? I’m still receiving emails and the sites load, but I’m not sure how much of that is from the previous setup vs 0.26b.


The update worked for me after a second attempt (drive was full the first time)

Move the mailinabox git folder: mv mailinabox mailinabox.backup and then re-run setup.

Already tried this as stated above in not so many words, thanks for the suggestion. :slight_smile: It seems like the install is getting stuck somewhere, even with a freshly downloaded version. The install at minimum is not finishing updating the config files as I stated above.

I can still login the the web interface and my account is listed as admin, but the daemon seems to be having issues with the username/password/API? Is there another way I can reset the API key besides ‘service mailinabox restart’?


Those ones could be of help: Old management deamon without virtualenv still running after upgrade and/or v0.26 - Let’s Encrypt won’t work (Certbot problem), can’t install, the same applies to upgrading.

Yes, that looks like exactly the same issue, thanks @just4t.

Killing mailinabox, deleting /usr/local/lib/mailinabox and rerunning the setup seems to have resolved the issue. Thanks for the help.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.