Error installing a new machine in 18.04.2

I want to upgrade my mail-in-a-box installation from ubuntu 14.04 to ubuntu 18.04.2 (i suppose that this is the right version), but i have this error.

Installing Postfix (SMTP server)...

FAILED: apt-get -y -o Dpkg::Options::=--force-confdef -o Dpkg::Options::=--force-confnew install postfix postfix-sqlite postfix-pcre postgrey ca-certificates
Reading package lists...
Building dependency tree...
Reading state information...
ca-certificates is already the newest version (20180409).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 postfix-sqlite : Depends: postfix (= 3.3.0-1) but 3.3.0-1ubuntu0.2 is to be installed
E: Unable to correct problems, you have held broken packages.
root@boxcorreo:/home/marcosms# lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 18.04.2 LTS
Release:	18.04
Codename:	bionic

I think that it is caused by the version of ubuntu, isn’t it? Or it must be another error. This is the server version of ubuntu. Can it be solved in any way?

I have this in /etc/apt/sources.list

deb bionic main
deb bionic-security main
deb bionic-updates main
deb bionic universe

problem solved. I add the universe source by adding it in /etc/apt/sources.list instead of addin it by command line with this command

sudo add-apt-repository universe

With this command the problem were solved.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.