Error connecting to Milter service

I’m seeing a lot of error messages along the lines of this in my mail.log. What does this mean, and what are the implications of this?

warning: connect to Milter service inet: Connection refused

Sounds like the same problem @uca is having on Public DNS (nsd4) is not running ([Errno 111] Connection refused; port 53)

It means your opendmarc process isn’t listening. To get it running again, have you tried restarting the box?

I don’t know why it stopped running… The logfiles in /var/log might have a hint.

Ah, thank you. That’s exactly it then. I did notice that opendmarc wasn’t running, but I didn’t realise it was related. Now to find out what opendmarc stopped.

how did you get it started?

To see whether it’s running in the first place, you can run this command:

service opendmarc status

If OpenDMARC is running, it should return the string, “opendmarc is running”. In my case, it was not running, and I had to restart it like this:

service opendmarc restart

Any idea why it stopped? Out of memory?

No idea, sorry. If it happens again, I’ll investigate further. This was running on a box with 1GB memory and not much in terms of email throughput.

it happened to me a couple of times as well, and I have found not reasons in the logs. Because I got a bit more mails, I have install monit to make sure it gets respawned in case it crashes.


I am starting to get a nightly status email from mailinabox saying OPENDMARC is not running, and I have no idea why it’s crashing/stops running. I tried looking in mail.log but that doesn’t seem like the right place to look for that error (I can see the “connect to Milter service refused” lines…)

I’ve seen elsewhere that maybe the box is running out of RAM? But I’m only around 40-50% usage average…