Enable PHP on sites

Hello miab users!,

I have a question, I have made a subdomain mail.****.nl. Putting HTML files there works perfectly, but PHP files dont. How can I make PHP files work?

Everytime i try to access the site, I get a nginx 403 error.
The rights are set to 0755, owner to www-data (I tried root aswell)

Regards, Thomas

Running PHP on websites is not supported on MiaB.

Is there a way to enable that? like installing a package or something else?

Look here Is atleast being able to toggle PHP planned?

That doesnt work :confused: I tried it

This still works for me without any problems.

Please be aware that customizations are not really supported.


It doesnt for me… I set everything up
Made the file, set permissions (owner www-data, 0644)
All system services running


I dont want to mess around too much, but would it be possible to delete roundcube? If that is possible i can upload my own index.html which redirects to the Rainloop installation on my NAS
(like I did with http://Hoeky.nl/webmail/

Mine is -rw-r--r-- (0644) but owned by user-data.

Still not working >.< Is there any way to redirect Hoeky.nl/mail/ ?

This will not change the way nginx serves index files (index.php files will not be served unless done by name: http://example.com/index.php works, but http://example.com/ will show a 403 error.)