Dumb question - please, don't shoot

Hello, everybody.
I have the following issue:

  • fresh install of Ubuntu server, fresh install of Miab, brand new domain: danpacu.com (with namecheap).
  • I CAN login via browser - just set up everthing ok, works, sends/receive mail - so everything is simply great.
  • I CAN’T log in on my laptop. - the Miab installation changed from dan@danpacu at something@box - I tried admin and passwd admin, I tried the dan (user) and the passwd I set during installation (which allows to acces via browser my miab instance), and nothing. What exactly did I do wrong???
  • is there any chance to change the box hostname to the previous one - danpacu? will it affect the functionality of my Miab instance?
  • how can I log in on my laptop (note that via ssh, I can log prefectly fine - I tried it from my mac and also from my raspberrypi using the ssh-copy-id -i command).
    Thanks in advance for your help, and just as I stated in the subject: please, do not shoot me for such a “wierd” problem… jeje

Edit: also, I can access the admin panel using public_ip/admin, but if I try https://danpacu.com/admin I get error. Any suggestions, opinions on why this happens? With: box.danpacu.com - Mail-in-a-Box Control Panel it works perfectly fine.

I’m not really clear on your specific problem.

If one device you are able to log in from and another you are not able to log in from, then the problem is with the device.

What are you trying to achieve by changing the hostname? This can cause problems and usually nobody notices except an admin.

If you are able to log into the admin dashboard using https://box.example.com/admin, that is how MiaB is supposed to work. It doesn’t load the admin dashboard on example.com/admin.

Thanks for the explanation. After all, if I can send and receive email I’m ok.
The problem is that once rebooted the laptop where th miab is installed on, I wasn’t able to log (except via ssh form another computer e.g. mac or raspberrypi) - thus my question about changing the hostname.
When you say: “This can cause problems and usually nobody notices except an admin.” - what kind of problems do you mean? (reception/sending email? other?).
Funny thing - just tried to access: https://example.com from moy mobile phone, using WAN, and it took me to the welcome screen of miab (e.g. “this is mail in a box…”). So, it works fine, doesn’t it? Simply cannot understand why from my mac, using firefox I get the previouslymentioned error.
Thank you very much for your answer and help. It really helped me understand just a bit more about miab!

I’m missing something in your problem description here…Are you running MIAB on a VPS, or are you trying to run it at home?

Specifically, when you say you can login to the web interface via a browser and to the CLI via an SSH session, but not “from your laptop” what exactly do you mean by that?

I run it on my laptop. And there, on the very laptop, once rebooted I can’t log in. I get stuck at the step: box login:
But as I mentioned, via ssh or browser I get no problem at all. So, it works, but I think I am the real problem - not fully understanding how it really works… and I’ll try changing the hostname and see what happens. THis install was supposed to be the last trial, before having it fixed and ready to work nonstop as my primary mail service. But maybe I rushed a bit … jeje. Thanks a lot for the interest, anyway.

On the device running Ubuntu Server you should see just the console login, which is your Ubuntu username and password.

If you are a new user of Ubuntu Server or new to mail servers, I do not recommend changing things like the hostname unless you are just doing this for testing or learning.

THanks a lot for the answer. Just what I needed. This morning, after reading your message and a simple reboot, just in case, everything is working perfectly. I could login on the device running Ubuntu, I can access my miab instance without any problem.
Just a last question: the only warning I get is related with the reverse DNS: “Your box’s reverse DNS is currently [Not Set] …”. But I understand (from my readings on the web) that this issue is to be solved by my ISP, not by myself working on my bind server, right? If my ISP won’t solve it, would it affect my miab functionalities? Will it sort of “slowing down” the miab functions, or no?
Again, thank you all for the interest shown and for all the help you all gave me. It’s reassuring knowing that there are people (like you) willing to help.
Thank you all, very much indeed.

The reverse DNS record is for forward confirmed reverse DNS (FCrDNS) checks. It is used as a proof of work test against spam. The worst case is some mail servers may consider mail from the server as spam permanently without passing such a test.

Actually, the worst case scenario is that MANY mail servers will reject your emails completely. Not having rDNS is near fatal in many situations. @danp

There are probably like, what, 100 million mail servers? What is some and what is many?

Hi, everyone.
Thanks a lot for the explanation. (@openletter, @alento).
Now I have to start figthing with my ISP. Wish me luck… :slight_smile:
Once I solve the situation, I will let you all know.