"DNS resolution failed" Nameservers don't seem to update?


I’m running Mail-in-a-box inside a VM. I was previously running the SoGO fork on 16.04 without any problems but wanted to use the newer version so I went back to this.
The VM has it’s own IP address and is exposed to the network as if it were it’s own machine, so there’s no need to port forward or anything.
A few hiccups (didn’t know that I absolutely had to have ssh installed for stuff to work?) but for the most part it’s kinda working.

My only issue now is that it can’t seem to resolve DNS updates, Here is the error I get when I run sudo mailinabox.

I’m using MIAB with the subdomain “mail” but even with the default “box” it still didn’t work, I just set to mail so I didn’t have to update the nameservers for a bunch of domains.

I already tried some stuff in an attempt to fix it but I’m not even sure what I’m looking for/trying to fix.

Thanks for any advice.

Not sure what happened but it seemed to have gotten stuck partially being on the box subdomain.
I’ll just do default everything and see if it updates, since it was stuck prior.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.