DNS issue? rejected user on seconded email account



I have serveral email addressess running off a single mailinabox v0.21c installation and working well. My issue is with adding a second email address to a domain which does not have is nameserver records pointing to teh MAilinabox server.

email1@domain.com - works fines
email2@domain.com - not working - Sender address rejected: not owned by user

not sure if there’s a issue with the domain DNS or something but I feel like I’ve tried everything and still not working.

DNS settings for domain.com:

  •       A                178.62.x.xx

@ A 178.62.x.xx
www A 178.62.x.xx
mail A 46.101.x.xx

  •           TXT/SPF        v=spf1 mx -all

@ TXT/SPF v=spf1 mx -all
www TXT/SPF v=spf1 -all
ns2.mail TXT/SPF v=spf1 -all

  •        MX    20        mail.mailinabox.com.    

@ MX 10 mail.mailinabox.com.


What does the status checks say?

  • :heavy_multiplication_x: The nameservers set on this domain are incorrect. They are currently
    ns.123-reg.co.uk; ns2.123-reg.co.uk. Use your domain name registrar’s control panel to set the nameservers to ns1.mail.nicegrp.com; ns2.mail.mailinabox.com.
  • ✓ Domain’s email is directed to this domain. [domain.co.uk ↦ 10 mail.mailinabox.com]
  • ✓Postmaster contact address exists as a mail alias. [postmaster@domain.co.uk ↦ administrator@mail.mailinabox.com]
  • ✓Domain is not blacklisted by dbl.spamhaus.org.
  • :heavy_multiplication_x: This domain should resolve to your box’s IP address (A 46.101.xx.xxx) if you would like the box to serve webmail or a website on this domain. The domain currently resolves
    to 178.62.x.xx in public DNS. It may take several hours for public DNS to update after a change. This problem may result from
    other issues listed here.
  • ? This domain’s DNSSEC DS record is not set. The DS record is optional. The DS
    record activates DNSSEC. To set a DS record, you must follow the instructions provided by
    your domain name registrar and provide to them this information:


Correct me if I am wrong, but this looks like the verbiage within Roundcube when sending from an alias that is not correctly set up.

OP - Where are you seeing the error message you referenced? Was email2@domain.com set up as a user or an alias?


Hit it on the nose there! it was a last resort and saw that there was an alias set up. after it was deleted the mailbox started working!



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.