DigitalOcean: SMTP (port 25) is now blocked for all new accounts

Just saw this note in the newsletter.

SMTP (port 25) is now blocked for all new accounts to help prevent spam and other abuses of the platform. Learn more about SMTP blocking and sending emails from DigitalOcean here.

Such a shame. Guides for newbies will have to reflect this change.

1 Like

A lot of cloud providers block it by default on new accounts, UpCloud do it for example, but if you contact support and make a valid use case then they will unblock it for you. Do we think this means that DO will no longer do that?

Linode blocks port 25 by default also. It’s just a matter of opening a ticket and asking for them to be opened.

Been this way since January 2011. Nothing new.

But I will remind everyone that I do offer a simple inexpensive reliable SMTP relay. For details see

1 Like

I use DigitalOcean and never had an issue with the service itself send or recieving email. I don’t think it was blocked by default when starting, but it’s not too much to ask that new users request that port be opened given how simple it could be to setup and recreate a spam operation without that.

Thanks all. Yes all good points. I guess by blocking port 25 by default with an option to open by request it gives legitimate services (like MIAB) a better reputation when sending from DigitalOcean.

1 Like

I use digital ocean myself (over 3 years with little issues except for the extortionist practices of UCEPROTECTL3 - so I don’t send mail to outlook.com places). But in when I just updated MIAB I noticed that in the status it gives me the error:

“Outbound mail (SMTP port 25) seems to be blocked by your network. You will not be able to send any mail. Many residential networks block port 25 to prevent hijacked machines from being able to send spam. A quick connection test to Google’s mail server on port 25 failed.”

I think this is caused by the check which first used ipv6. I modified /etc/main/postfix.cf and changed

inet_protocols = all
to
inet_protocols = ipv4

and did a service restart postfix, and then from the status I get no error anymore:

“Outbound mail (SMTP port 25) is not blocked.”

If you check the syslog, I found the following which led me to the changing that parameter:

postfix/smtp[11173]: connect to gmail-smtp-in.l.google.com[2607:f8b0:4004:c06::1b]:25: Network is unreachable

Not sure if this helps but - at least if cleans up my status in the admin portal.

A better solution may be to disable IPv6 in Ubuntu.

Good hack @Tony. I don’t have any issues on my DigitalOcean existing setup. However, pretty sure I followed the guide here.

If you have a choice, choose a location for your machine that is near you — it’ll be faster! And if disabling IPv6 is an option, disable it.

Which I suspect results in disabling IPV6 at the OS level as per @openletter ’s suggestion.

Maybe DO only kept port 25 open on existing accounts for IPV4 connections.