Digital Ocean NYC2 Zone - Undelivered Mail Returned to Sender (Hotmail, Outlook, Gmail)

Interesting find concerning Digital Ocean and the NYC2 zone. I built a new MIAB in the NYC2 zone (IP range 162.243.xx.xx) and everything worked fine until i was getting emails bounced back from gmail and hotmail servers with the following results:

Final-Recipient: rfc822; Original-Recipient: rfc822; Action: failed Status: 5.0.0 Remote-MTA: dns; Diagnostic-Code: smtp; 550 SC-001 (SNT004-MC3F7) Unfortunately, messages from weren't sent. Please contact your Internet service provider since part of their network is on our block list. You can also refer your provider to

I had checked to ensure that the IP was not blacklisted on multiple sites with no issues on the IP or my domain name(s). I sent the emails directly from the Roundcube webmail site to make sure it was nothing was happening between my outlook client, router, etc.

I have about 6 domains on my MIAB setup so i tried to email the recipient from all email boxes. All of which returned the same result almost instantly.

My last resort was to take a snapshot of my Droplet, create a new one and restore my snapshot to the new droplet on build. I created this new droplet in the same NYC2 zone and got a different IP, but still had (IP range 162.243.xx.xx).

I then checked to ensure this new IP was not blacklisted anywhere and then took the following steps on rebuild:

  1. Changed my glue records at my registrar to the new IP (162.243.xx.xx)
  2. Edited my /etc/hosts as described in setup of MIAB to new IP
  3. Re-ran curl -s | sudo bash to configure with new settings

Again, i got rejected emails sent to Gmail, Hotmail, etc.

I realized that i had actually never deployed any of the MIABs i’ve built to this zone so i decided to try another Zone and followed the same steps above in the NYC3 zone (IP range 45.55.xx.xx).

Worked just fine, no rejected emails.

Is there anyone here who has a MIAB in NYC2 zone on Digital Ocean that didn’t have this problem? I’ve built multiple MIAB in other zones in NYC with no issue, but never in NYC2 until today.

Or, maybe if anyone has this same issue in the future and happens upon this post it will help solve an issue.

My DO box is in NYC3.

Right, mine is too. Working just fine there, but will not work in NYC2.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.