Custom DNS with CNAME (no A Record) because Webserver is AWS ELB

In AWS Route 53 (DNS service) I choose A Record TYPE and then select “alias”, which allows me to paste the following into the VALUE field:

I suppose this is similar to CNAME, but how should I do this since I am moving the route53 dns stuff to MIAB DNS??

so i figured out this part about CNAME. But it seems that the box isn’t updating records correctly. I even restarted the nsd service and checked the & files as well as the zones directory.

Everything seems fine but when I run dig (even after clearing dns) it doesn’t update. the first time I added the CNAME I omitted the trailing DOT (.)

when i ran dig it added at the end of CNAME value.

so, i added the trailing DOT in CNAME as shown below, I checked the zone files and they were updated but dig and other checks showed no update. in addition, when I run localhost dig, it returns No Such Domain (NXDOMAIN).

Please help. this box worked when I used AWS Route53. CNAME [delete] CNAME [delete]
* CNAME [delete]


So, it turns out that you MUST delete the CNAME record with the error before adding the fixed CNAME record if they are similar/same or the file will ignore the updated file. In addition, I found out that you can not use * in a CNAME to redirect to - so I just added the redirection to nginx conf file as an IF stantement for both non-www to redirect to www and https://non to https://www
the ssl 443 if statement will also work to send https to http

this drove me bonkers for about 13 hours today.

Hey @uca,

I just wanted to note that you may need to add that nginx change again after updating MIAB.

thanks. I’ll try to remember when update. Also, I ran into a related issue as well that i keep coming back to:

I added the following to my custom DNS. When I used external DNS I don’t think I went to spam Using Amazon SES to send emails. I am now going to Spam with my AWS SES newsletter. I added the DKIM stuff as show below. What is the record indicating that AWS SES is not allowed to send on behalf of or what modification can I make to allow SES to send on or There has to be a way to allow this without too many compromises? no?

Domain Name Record Type Value CNAME [delete] CNAME [delete] CNAME [delete] CNAME [delete] CNAME [delete] TXT v=spf1 mx -all [delete] TXT N4IUtq57cuiOqz3vhM=

OBVIOUSLY, I deleted some of the text above for security…even though I don’t know if it matters… LOL.

@uca: I think you’re right in Custom SPF Record, I think we covered this issue there. Let us know if we didn’t.