Critical warning about inode usage

In the munin report I’m seeing a critical warning about inode usage being 99.5% - any idea if this is a big problem. So far I’m not seeing any symptoms

(Apart, that is, from the return of an old problem with downloads disappearing. I can’t remember how I solved this last time, but I don’t think it had anything to do with inodes.)


Is this on a newly installed system or are you on ubuntu 14.04 or 18.04.

The error means, your disk is almost full (but not physically).

You can verify your node usage with ‘df -i’
in my case:

/dev/mapper/box--vg-root 9773056 662340 9110716 7% /

The cause is a lot of small files, which is quite common for a mailserver.

the other question is: on with disk is this caused. The datadisk of the mailserver or “something” else.

1 Like

It’s Ubuntu 14.04.5 LTS. The system’s been running a couple of years

root@box:~# df -i
Filesystem Inodes IUsed IFree IUse% Mounted on
udev 58079 387 57692 1% /dev
tmpfs 62518 378 62140 1% /run
/dev/vda1 1305600 1298945 6655 100% /
none 62518 2 62516 1% /sys/fs/cgroup
none 62518 1 62517 1% /run/lock
none 62518 1 62517 1% /run/shm
none 62518 2 62516 1% /run/user

That’s a serious problem; you have to look in how to increase inodes, but this could be a problem.

Maybe the most simple step is just upgrade

If you are going to try something, verify you have a good snapshot/backup

The culprit was /usr/src which had a lot of linux kernel headers. I mounted a second volume, moved the contents of /usr/src to a directory there and made a symbolic link from /usr/src to the directory.

Another suggestion I had from Aletto was to run apt-get autoremove

In my case the problem was with client software that was set up to connect mailinabox via Exchange protocol. Something went wrong and those clients started to DDOS the mailinabox server. The solution was:

  1. Check what client is ddosing your server: run /milinabox/management/ The mailbox you are looking for will have hundreds/thousands of imap connections.
  2. Set up the Outlook of that user to use imap instead of Exchange
  3. Reboot the user’s computer.

In my case the problem was solved.