Correct charset in nginx

Hi guys, I’m a new user of Mail-in-a-Box (started this morning) and I’m already loving it!

I changed the landing page to show my contact information, but the page seems to be served using the wrong charset. I’m also new to nginx so I googled it and found that I should add charset utf-8; in the server {} declaration of my NGINX configuration file.

I went ahead to do this but found a warning in the config file that says I should not modify it because MiaB will overwrite it.

Can anyone tell me if this is something I can modify in any way? It says in the same note to not ask for help regarding this config, but maybe utf-8 should be a standard setting? My native language (and my landing page language) is Spanish, and now “Consultoría” is served as “Consultoría”.

Thanks for any help no this matter.


Usually creating new files is not overwritten by MiaB.

In most nginx installs, you can add a configuration file to /etc/nginx/conf.d/ and that will work for anything universal to the nginx http block, though not an individual server block.

So I think you can just create /etc/nginx/conf.d/charset.conf and just put in the file charset utf-8; to get this to work for you.

Thanks! I’ll try that as soon as I get a new VPS running. I just found out that Digitalocean now blocks port 25 for new instances, so I can not host my MiaB there.


Try sending support a ticket.

I did, and unfortunately the informed me that they don’t open this port for new instances. They suggested some workarounds which I think would take a lot of my time to implement. I told them that I just want to make it work without giving it much time, and that I would look for a different provider if they didn’t open the port. Then they suggested the same workarounds and told me they cannot open the port at this time.

So I just left and now I’m looking for a different provider. Is Linode guaranteed to open this port? Do you have any suggestion regarding other vendors?


Does this policy apply across all data centers?

They really didn’t say. Here’s their last response:

Unfortunately, each account is evaluated as its own entity. We are very sorry, but we are unable to remove the restrictions on SMTP on your account at this point in time.

We realize this is inconvenient, but many customers in your position move their mail activities to a third party service such as SendGrid or similar, which will process mail separately from their droplet.

In terms of a workaround, here are a few alternatives:

  1. Utilize a 3rd party mail API, we don’t officially affiliate with anyone but one option is Sendgrid:

  2. Utilize a non-default SMTP port like 2525. Sendgrid also offers this:

Please feel free to reach out to us if you have any additional queries. We’re always here for you!

Really crazy policy in my opinion. I offered to update my droplet from $5 to $15 (I can use it for other projects), but it didn’t help. Maybe they should just monitor activity in suspicious accounts, instead of blocking it for everyone.

I’ve been using Vultr without issue, though some report they have to request port 25 to be opened.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.