Connecting to failed: Network is unreachable

Hello, everyone.
I just ran into this installing error:

As I am a newbie in this, could anyone shed a light on how could I resolve this issue?
Thanks a lot in advance…

It looks like MiaB can’t connect to Have you tried again since posting this? I am able to connect to that domain from the U.S.

I tried the bash script again, apparently worked, but when I access: hhtps://ip/admin I get now the 404 error. Plus got the warning of not being able to resolve the box.mydomain.tld. Man, this is difficult… jajjaja.
I don’t know what to do exactly: try to solve somehow the errors, fresh new install, abort everything…
Thanks for the interest, though… very kind of you.

What VPS provider are you using?

THe install is self hosted… on a laptop I plan to use as a mail server - toshiba tecra - an old one
So, therefore my problems… plus I am not an IT trained specialist…just an amateur, so still learning…

If MiaB is behind a network gateway, are you using a local IP address? MiaB should still work this way.

And you did install Ubuntu Server 18.04 (not Desktop version)?

Keep in mind, you are going down a harder road right now with MiaB, because hosting locally, while possible (I did it for a couple years), is more difficult than using a VPS provider.

You might have better luck setting up first with a VPS provider, figuring out how to use MiaB, then migrate to a local machine.

Thanks for the advice. I will take it into account. Meanwhile I continue struggeling with this.
Thanks, again, for taking an interest in my issues.

To assist you further, can you please respond to my other questions? The last comment was just a suggestion, not saying there isn’t a way to achieve what you are working toward, but it will be difficult to assist you without a clear understanding of your setup, as your problem suggests there is something highly unusual somewhere that is specific to your setup, so we have to figure out where that is (MiaB is installed on over 20,000 active servers and these forums get only a few posts per day, so problems are highly infrequent).

Not at all am I questioning the MiaB. It’s just me, and my lack of a better knowledge that causes me problems.
And forgive me for not answering completely before: of course I am using a Ubuntu Server 18.04 instance (on a laptop- Toshiba tecra s4, dated arround 2006 - not entirely sure). Brand new install.
My real problems come when dealing with (or - yesterday I registered “my domain”, so I am a total newbie in this world, and still very confused with all the terms involved.
As said, I am the problem, not necessarily MiaB. SO please forgive me for being me the problem. I will try some changes in my DNS zone (the provider of my account has a section dedicated to it - in Spain). and I’ll get back to the fight.
By the way, is there a way to try and change settings without doing a full SO-MiaB fresh reinstall?
So, indeed, please excuse me for my lack of thorough knowlegde on this subject, and thanks for dedicating your time to my issues.

As long as the hardware is running a 64-bit chip, you should be good to go, but do note that a server is harder on storage drives because there are many more writes to disk than with typical desktop usage (assuming you have SSD - if you have HDD, the problem is different and worse).

MiaB is automatically configured to be its own authoritative DNS server by using glue records set with your registrar ( and If you want to use a different DNS server, you will need to first install MiaB, then log into the admin dashboard and configure your DNS server provider as per the instructions on the ‘External DNS’ page of the dashboard.

Have you verified that your IP address is not on a blacklist? You run the test at this website:

Have you verified your local ISP is not blocking critical ports, such as port 25?

As far as changing settings, you will have to be more specific as to what you want to change.

Well, well.
Just as I said before - the problem was me.
Untill now I fixed the following:

  1. A new A name register for my domain.
  2. Access to the miab instance by accesssing: https://lan_ip/admin and not https://public_ip/admin. So I am in! Can’t believe it.
  3. A priori the port 25 isn’t blocked.
  4. ANd thanks for the checking ips site. Just checked my ip and, affortunately, isn’t blacklisted.
    SO, two steps forward. Thanks for your time and advices.
    As for changes, I tried sudo mailinabox and changed the domain - instead of just put Now I start on the check status of miab to see what do I have working, or not.
    Much obliged for the help received.
1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.