Completed install, nothing listening on ports

Hello everyone, hope you’re all staying safe and had a nice weekend.

spun up a new vm today with Ubuntu 18.04 LTS fresh install as requested by the guide.
the installation looks a bit different to the guide but thats fine.

Primary Hostname:
Public IP Address:
Private IP Address:
Mail-in-a-Box Version: v0.50

Updating system packages…
Installing system packages…
Initializing system random number generator…

After this, i get nothing else which obviously looks different to the guide.
I checked /admin nothing there. check netstat nothing listening.

any advice on what possibly could be wrong?

Kind Regards

Not really enough information given at this point.

Who is your VPS provider?

How so?

Hello Alento,
I’m the provider, looks like the installation isnt completing, as no services for mailinabox are installed, no listening on ports.

iv tried the direct curl method, have also tried the git clone.
what information would you require? having a look in syslog doesnt seem to have anything, and i dont see any log folders inside the installation.

as for the guide I never get to this part:
Your Mail-in-a-Box is running.

Please log in to the control panel for further instructions at: 

only thing i ever see after running the setup/
Updating system packages…
Installing system packages…
Initializing system random number generator…
then it puts me back to console.

Any advice would be appreciated, where to look for errors or if the installer has a debug option.

Kind regards

So a bit more digging into the code, seem the issue is pointing to
specifically FIREWALL section, commenting this out fully completes the install!
I Diagnosed this by following the trait what was the last echo I seen.
Initializing system random number generator…
which i found was in, after each bit of code I force it to echo so i can see where exactly it is failing.

really need to get logging into your scripts.

That’s it up and running, I can only assume its a failure to see that SSH is not running so it fails, some catch statements will fix that. Cheers

Yes, MiaB installation scripts require ufw and sshd installed on the system. Otherwise, they fail without any visible error.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.