Certificate problems after moving mib to new server

I had MIB working for over a year on a server - backing up to Amazon s3. I installed mib on a new server instance - ubuntu 18.04, clean nothing on it. Installation went fine. I copied the s3 backup files to a folder on the new server and ran

systemctl stop mailinabox
export PASSPHRASE=xxxxxx
sudo -E duplicity restore --force file://MyBackupFolder /home/user-data/
systemctl start mailinabox

All accounts are there along with all the mail. But I can’t get the ssl certs installed. After looking around forums and such I tried copying the ssl folder to a backup, deleting everything in it and running the ssl script in the management section. No luck.
tried running sudo mailinabox - no luck

Re instanced the ubuntu 18.04 with a new install and when through most of the above steps - no luck.
I’ve tried re-provisioning - that didn’t work.

I run the ssl_certicates.py and get
FileNotFoundError: [Errno 2] nosuch file or directory: ‘/home/user-data/ssl/ssl_ceriticate.pem’

So I tried moving the ssl_certificate.pem from my backup back in the ssl folder and re-ran ssl_certificates.py and got OSError: [Error 22] Invalid argument: ‘/home/user-data/ssl/ssl_certificate.pem’.

And then I came here.
I’m just guessing here but it when I did the restore does that over write a certificate that is particular to the server it’s on? Just guessing.

Help would be appreciated.
thank you.


Care to hop on to Slack? Much easier to diagnose in real time rather than on a message board. :slight_smile:


Of course - wasn’t sure which was the better to use.
Thank you.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.