Certificate becomes symlink to itself


#1

Hi,

Overall I am extremely happy with MIAB, especially your combination with Nextcloud making it effortless to create your own private cloud.

So far I was running MIAB with a wildcard certificate I had created with a 3rd party. However that one is expiring in a month. I had some issues installing the certificate, resulting in me symlinking the MIAB’s private key and certificate to my own private key and certificate (the certificate for one of the domains running on this MIAB). Everything worked, until last night at 03:00.

I think last night it automatically tried to renew this certificate, it is expiring in a month. The symlink ‘/home/user-data/ssl/ssl_certificate.pem’ became pointing to itself, MIAB stopped working (dovecot stopped working, postfix stopped accepting TLS connections). When I click to issue letsencrypt certificate in the admin interface, the same thing happens.

I dont’t have a wildcard certificate for this domain anymore. I would like to use letsencrypt to generate certificates. Can you tell me how to achieve this; how to fix the letsencrypt set up?

Thank you!

When I use the letsencrypt option in the admin menu,


Unable to use lets encrypt after upgrade to 0.40
#2

Delete the CONTENTS of the directory /home/user-data/ssl/ but do not remove the directory itself!
run ‘sudo mailinabox’ from the command line.
This should ‘reinstall’ mailinabox which will regenerate the SSL certificate and Let’s Encrypt account. One caveat, you should already be on at least v 0.28. If you are on an earlier version it may not work cleanly.


#3

Hi Alento,

Thank you very much, this fixed my issue!