Certain sender emails always goes into SPAM folder


I have emails that come from a certain domain / IP that always go into the SPAM folder. We have tried to train spamassassin by moving the emails out of the spam folder into the inbox and left them there for a couple of days. When we get an email again from the same domain /IP it goes back into the spam folder again.

Is there a way of adding the domain / sending ip to a whitelist so that they get delivered straight into the inbox.


You can white list using spamassasin I believe, you will have to google to confirm.

I too had this problem, what I did to fix it…

nano /etc/spamassassin/local.cf

then I added in at the top…

whitelist_from xxx@yyy.com

Be warned, evil can spoof that address and get through, so there are other options such as

whitelist_from_rcvd xxx@yyy.com <— This will check the recieved headers and rDNS/PTR record, so harder to spoof, but in my case, it was a business using a 3rd party mailer, so they had to spoof, so it would fail this check.

I’m not sure if this fill will be overwritten or not by Josh’s scrips, but it’s easy to put back in if it does (eeek, unless it’s overwritten nightly)

Hope this helps.

edit: typo

@usachris Cheers, that seems to work and helps a lot :slight_smile:

@JoshData would this be something we could add into the admin panel as a feature to whitelist certain addresses / domains as well, as the spam training which doesn’t seem to be behaving as it should be at the moment by dragging emails out of the spam folder into the inbox.

1 Like

Yeah I think that’s reasonable.

Do you want me to add it to guthub to track it



Yes please. (I only track things that are posted on github.)