Cert renewal failed, fixes didn't work - need professional (paid) help

We have MIAB running an older version (we need to do because of another application that connects to it)

MAIB is on a Vultr box

DNS is on AWS Route53

We had cert renewal failures, we tried to fix it with a temp DNS change away from AWS
It partly worked (renewed some mailboxes but not all)

Now we still need cert renewed on the other mailboxes PLUS more worryingly mail sent is not being received, this is a major problem

Happy to pay for professional help - need this fixed ASAP


what fixes did you try?

did you run setup again?

sudo mailinabox

No - didn’t try that (concerned about the upgrade issue, as we must stay on old version - for now)

We moved the DNS from AWS Route 53 to Cloudflare - then the Lets Encrypt worked on the mailbox domain and emails flowed through again.

For some unknown reason AWS Route 53 and Lets Encrypt were just not working.

From cloud flare you need to point your server to your VPS IP. Did you do that?
Make 2 NS records:
ns1.box.somedomain.com >>> @
ns2.box.somedomain.com >>> @.

Make 2 A records
ns1.box >>> your ip
ns2.box >>> your ip
If you use box.

Rerun sudo mailinabox it dosent perform an update. Go to Admin SSL> hit provision all not a single one.


thanks - we got it all working again

Cloudflare = Let Encrypt working

AWS Route 53 = Let Encrypt not working