Can't send email to Office365. Delist not working - [resolved]


I’ve just set up my new MIAB and I must say it seems to be superb so far. However, I have one (fairly major) issue; I can’t send email to Office365.

When I do I get a bounceback with this error:

host[] said: 550
5.7.606 Access denied, banned sending IP [MY MIAB IP ADDRESS]. To request
removal from this list please visit and follow
the directions. For more information please go to (AS16012609) (in reply to
RCPT TO command)

If I go to the URL and request that the IP address is delisted it says it might take up to half an hour. When I try again an hour or so later, I get the same error.

I’m using a Digital Ocean droplet and my box is new (set up about 24 hours ago).

Does anyone know of another way to get onto Microsoft’s Office365 whiltelist (or off their blacklist)?



Hmmm. I tried again this morning and it seems to be working. Maybe I just needed to wait a bit longer. If it happens again I’ll post in here again.

In the meantime, if anyone has anything useful to impart on the subject, I’d be interested to read it.

Cheers :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.