Cannot update to newer version

when I run the update command I get an error:

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-4.4.0-127-generic with 1.
dpkg: error processing package initramfs-tools (–configure):
subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

as far as I can see the boot drive is full. What can I do?

root@box:/home# df -h
Filesystem Size Used Avail Use% Mounted on
udev 988M 4.0K 988M 1% /dev
tmpfs 200M 592K 200M 1% /run
/dev/dm-0 1006G 5.6G 949G 1% /
none 4.0K 0 4.0K 0% /sys/fs/cgroup
none 5.0M 0 5.0M 0% /run/lock
none 1000M 16K 1000M 1% /run/shm
none 100M 0 100M 0% /run/user
/dev/sda1 236M 225M 0 100% /boot

Thank you for any help!

Would this be the answer to your question?

Yes, I agree. First thing that popped in my head was too many kernels

Perfect - that solved my problem thank you :o)