Cannot set up on AWS


I’ve set up my “glue” and name servers to … and but I keep getting the same error every time I try to run mailinabox.
The specific error:
stty: standard input: Inappropriate ioctl for device

The rest of the code runs fine:

Mail-in-a-Box Version: v0.07

Updating system packages…
already installed: python3 (3.4.0-0ubuntu2), wget (1.15-1ubuntu1.14.04.1), curl (7.35.0-1ubuntu2.3), sudo (1.8.9p5-1ubuntu1), coreutils (8.21-1ubuntu5.1), bc (1.06.95-8ubuntu1), unattended-upgrades (0.82.1ubuntu2.1), cron (3.0pl1-124ubuntu2)
installing python3-dev python3-pip haveged ntp fail2ban …
already installed: ufw (0.34~rc-0ubuntu2)
Firewall is active and enabled on system startup
already installed: resolvconf (1.69ubuntu1.1)
installing bind9 …
already installed: openssl (1.0.1f-1ubuntu2.8)
Generating DH parameters, 2048 bit long safe prime, generator 2
This is going to take a long time
already installed: openssh-client (1:6.6p1-2ubuntu2)
installing nsd ldnsutils …
Generating DNSSEC signing keys. This may take a few minutes…
already installed: ca-certificates (20141019ubuntu0.14.04.1)
installing postfix postfix-pcre postgrey …
installing dovecot-core dovecot-imapd dovecot-lmtpd dovecot-sqlite sqlite3 dovecot-sieve dovecot-managesieved …
Creating new user database: /home/user-data/mail/users.sqlite
installing opendkim opendkim-tools opendmarc …
installing spampd razor pyzor dovecot-antispam …
installing nginx php5-fpm …
already installed: php5-json (1.3.2-2build1), php5-common (5.5.9+dfsg-1ubuntu4.6), libmagic1 (1:5.14-2ubuntu3.3)
installing dbconfig-common php5 php5-sqlite php5-mcrypt php5-intl php-auth php-net-smtp php-net-socket php-net-sieve php-mail-mime php-crypt-gpg php5-gd php5-pspell tinymce libjs-jquery libjs-jquery-mousewheel …
installing roundcube webmail 1.1.0…
already installed: dbconfig-common (1.8.47+nmu1), php5-cli (5.5.9+dfsg-1ubuntu4.6), php5-sqlite (5.5.9+dfsg-1ubuntu4.6), php5-gd (5.5.9+dfsg-1ubuntu4.6), php5-imap (5.4.6-0ubuntu5), php-pear (5.5.9+dfsg-1ubuntu4.6), curl (7.35.0-1ubuntu2.3), php5 (5.5.9+dfsg-1ubuntu4.6), php5-gd (5.5.9+dfsg-1ubuntu4.6), php5-fpm (5.5.9+dfsg-1ubuntu4.6)
installing php5-curl php-apc libapr1 libtool libcurl4-openssl-dev php-xml-parser php5-dev memcached php5-memcache unzip …
installing ownCloud…
sudo: unable to resolve host ip-172-31-16-199
creating sqlite db
already installed: php-soap (0.13.0-1), php5-imap (5.4.6-0ubuntu5)
installing libawl-php php5-xsl …
installing z-push (fmbiete fork)…
installing python3-flask links duplicity libyaml-dev python3-dnspython python3-dateutil …
Waiting for the Mail-in-a-Box management daemon to start…
updated DNS:
web updated

Okay. I’m about to set up for you. This account will also
have access to the box’s control panel.
mail user added
added alias (=>
added alias (=>
added alias (=>
updated DNS:
web updated

alias added
added alias (=>
added alias (=>

Your Mail-in-a-Box is running.

Please log in to the control panel for further instructions at:

stty: standard input: Inappropriate ioctl for device

You will be alerted that the website has an invalid certificate. Check that
the certificate fingerprint matches:


Then you can confirm the security exception and continue.

Looks like it worked fine. Would you mind opening an issue on the github project so I don’t forget to track down why stty: standard input: Inappropriate ioctl for device is appearing?

The problem is that when I try to click on the link. Nothing shows up. I tried to change it to none-SSL and it works. But the SSL does not work.

Have you opened port 443 in your security group?

Hi Josh,

I also get the below on installs.

stty: standard input: Inappropriate ioctl for device

I will open an issue for it on github so you can track it.