Cannot send from desktop mail client - can send from phone & webmail

I’ve got my box all set up. I am running an Ubuntu build on Digital Ocean. I have installed the $9 Namecheap/Comodo SSL cert for, I am running a self-signed cert for

Status checks are all good, except for the squawking about the self-signed cert for the top level domain.

Bear in mind that I am more or less the target future user for this - I know enough to type the commands I’m told to type, but I don’t really know where to go to troubleshoot.

The issue at hand: I cannot send using a desktop mail client on OS X(Apple Mail, Thunderbird, Airmail). I am able to successfully send mail using MobileMail on my phone, and using the webmail at Mind you, I can successfully receive mail on desktop mail clients, but that’s it. Note: the problem with a desktop mail client can be replicated on three different machines. I have tried setting up both manually, and by using the mailinabox.mobileconfig file. I used the mobileconfig file on both OS X and on my iPhone.

I’ve rebooted the box, and I’ve made sure that updates are ran.
Thoughts? Suggestions? I’m at a loss as to what is wrong.

Hello @cheddarbek,

What happens when you try to send from your desktop? Is there an error?


Immediately the message will go in to the Apple Mail Outbox. A few seconds later, Mail will produce a connection error. "Cannot sent message using the server . The connection to the server “<>” on port 587 timed out.

Mind you, I double checked my phone, and it’s set up to connect on 587 and has no troubles…

It sounds like your local network may be blocking outbound connections on port 587. Is that possible?

1 Like

Turns out, yes - I’m just a moron. I was testing both at work, and at home. I wasn’t surprised when it wasn’t successful at work, our network traffic is pretty well locked down.

What baffled me was at home, then I remembered that I use a private vpn to route all my network traffic. Disconnected from the vpn and it went right through.

Once again, the problem was the ass in the seat.

I’ve sent a request to my vpn service to whitelist my server - that way I won’t have to drop off vpn any time I want to send an email.

Great. Glad you got it figured out.

I’m having a similar problem at home. I can’t send through SMTP when connected through my VPN. Is there a setting somewhere on Mailinabox that I can change to make this work? Thanks.