Cannot send emails

after modifications related to BIND9 (replaced by Unbound) and NDS (service stopped) I cannot send any emails.
Here’s the error message in /var/log/mail.log:

Jan 21 00:51:07 miab postfix/smtp[942335]: 4179B42854: to=<>, relay=none, delay=0.45, delays=0.2/0.25/0/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for ty
pe=MX: Host not found, try again)

This is pointing to an issue related to name resolution, however dig returns correct IP:

❯ dig
;; communications error to ::1#53: connection refused
;; communications error to ::1#53: connection refused
;; communications error to ::1#53: connection refused

; <<>> DiG 9.18.18-0ubuntu0.22.04.1-Ubuntu <<>>
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 64276
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

; EDNS: version: 0, flags:; udp: 1232
;               IN      A

;; ANSWER SECTION:        3016    IN      A

;; Query time: 0 msec
;; WHEN: Sun Jan 21 01:03:10 CET 2024
;; MSG SIZE  rcvd: 60

Can you please advise how to troubleshoot this issue?

Well, this is definitely something for the Unsupported Modifications subforum :smile:
Looking at the dig output:

This suggests unbound is not listening to the ipv6 local address, so check that.
Also, enable nsd and see if that makes a difference.

I thought this setting enabled IPv6:

❯ head -n 20 /etc/unbound/unbound.conf.d/miab.conf 
    # If no logfile is specified, syslog is used
    # logfile: "/var/log/unbound/unbound.log"
    verbosity: 2

    port: 53
    do-ip4: yes
    do-ip6: yes
    do-udp: yes
    do-tcp: yes

    # You want to leave this to no unless you have *native* IPv6. With 6to4 and
    # Terredo tunnels your web browser should favor IPv4 for the same reasons
    #prefer-ip6: no

    # Use this only when you downloaded the list of primary root servers!
    # If you use the default dns-root-data package, unbound will find it automatically
    #root-hints: "/var/lib/unbound/root.hints"

You might also need
interface: ::0

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.