Broke Z-Push (Password Incorrect)

Greetings All,

I was tinkering under the hood last night trying to get Z-Push to work a bit better with contacts/calenders and I have managed to bork it up and now get the following errors whenever anyone trys to use activsync.

22/05/2015 12:29:01 [ 1985] [INFO] [] Version=‘SVN-trunk-r1913’ method=‘POST’ from=‘’ cmd=‘Sync’ getUser=‘’ devId=‘c89a7bd8c2984a519b114f051a5d262f’ devType=‘WindowsOutlook’

22/05/2015 12:29:02 [ 1985] [WARN] [] BackendCalDAV->Logon(): User ‘’ is not authenticated on CalDAV

22/05/2015 12:29:02 [ 1985] [INFO] [] AuthenticationRequiredException: Access denied. Username or password incorrect - code: 0

Is there an easy way to put z-push back to it’s normal default settings? The username and password do work in all other services by the way, it is just z-push that has an issue.

I did get the issue resolved. Decided to play it safe, spun up a new box and copied the user-data directory over, swapped around the IP addresses, all is good now.

I know it’s a bit late to reply to this thread; However, I recently had this problem, and what worked for me was to go into owncloud and create an application password, using this password when setting up the iPhone exchange mail account worked, and didn’t keep asking for the password over and over again.