Brave keeps redirecting to mailinabox domain

I was messing with a mailinabox vm server running on the same home network as a nextcloud vm server. It must’ve been configured wrong, because I wasn’t able to access the admin or mail pages, even on the mailinabox server’s local ip. so i ran “sudo mailinabox” and restarted the setup process. But this ended up causing Brave browser on a separate Mac computer [that i previously used to access nextcloud] to keep redirecting from nextcloud’s subdomain [] to mailinabox’s subdomain []. I’m assuming this was due to a change made as part of “sudo mailinabox” but I have no clue how to correct it. If anyone can give me some assistance, I’d greatly appreciate it

brave might just flat out be bugged. i ran the sudo setup again, but

  1. attempting to connect to [local ip]/admin causes it to redirect to and complain “ redirected you too many times”
  2. on the host computer, firefox works fine. edge works fine. even on the same computer as brave, connecting to through safari works fine. so ig now i gotta figure out what went wrong with brave…

apparently clearing “Cookies and other site data” and “Cached images and files” across “All time” did the trick. I was previously trying to be careful and only delete cookies related to and but neither worked.
now there’s the next issue of why trying to connect to my mail server’s local ip causes brave, safari and edge [but not firefox] to automatically redirect to, but that’s for another day…

i’d mark this post as the answer but i don’t see the option