Box not receiving?

on the 15th my box stopped showing me my email. it seems to receive (testing from know good accounts gets no bounce), DNS is correct, what am i missing?


How do you check your e-mail? Did you try the webmail? Can you send email?
Perhaps the admin status page shows something interesting?

for testing i’m using the webpage, no new mail. i can send from the webpage and other clients
admin panel shows a new version, and nameserver glue error. all the important ones are green


  • which version are you on?
  • are you using any deviations from the default installation?
  • nameserver glue error should not be there
  • what do the unimportant errors and warnings say?

Another source of information might be the mail log: look at /var/log/mail.log and look for the email address. There should be a number of lines for a single mail transaction and they might contain information pointing to an error.

i’m on 64. i am running a different zpush then stock
Nameserver Glue is not required for MiaB to work properly. I elect to manage DNS myself, that’ s not for everyone.
unimportant errors indicate that the website for my box name and for my root domain do not point to my box.
remember that this worked until 2 weeks ago.

thanks for the tip about the log

the mail.log agrees that no mail has been received.
could it be fail2ban? what would prevent the box from receiving?

rebuild works fine, so i guess the box just broke. thnx for the log tips

If you’re sure the remote mail server does not even try to connect, it could be several things: e.g. firewall, or indeed fail2ban. Also possible is that your MX record is not correct (but unlikely as this happened suddenly).
Try a tool like this one. Perhaps it gives a hint. Just fill in your domain name, it should lookup your box ip address.

mxtoolbox worked fine, but nothing ever showed up. they can telnet into your server and send as someone you list. I really have no idea, i never got a bounce anywhere ( testing from several external emails), and that log didn’t show any of the tests i was sending.
DNS wasn’t it because i spun up a new instance and it works perfectly.
there was some modification to zpush, as it didn’t work correctly with the last build. that must have been it

Good that it works now.
If mxtoolbox works fine, it should show something in your mail.log. If it does not, it didn’t connect to your mailserver. It is not supposed to actually deliver an email.

i’m thinking the whole server was just broken.
it was crazy that mxtoolbox sent an email to my account and nothing showed up in the log