AWS S3 Backup after upgrade to V61

Posting this to help anyone that may run into this issue because the error messages are not very descriptive.

Over a week ago I upgraded my MIAB to v61.1 from v57 following the steps under Moving to a New Box. For the most part it went smoothly and I was able to restore from my AWS S3 backups.

After the upgrade, backup status reverted backups as stored to Box. I re-entered my S3 bucket and access keys and received a “500” server error.

I tried the following:
-clearing backup cache
-running sudo mailinabox and rebooting
-checked S3 bucket, credentials and IAM policy (all correct)

None of the above worked.

I discovered the custom.yaml file under /home/user-data/backup was not updating so I manually entered bucket and key information and ran a backup. Every back up attempt failed with: Backup Error ‘Contents’. Turns out the issue was simply a trailing slash after my bucket name.

The ‘500’ and ‘Contents’ errors are now gone and backups are working.