After Upgrading MIAB when switching back to MIAB DNS Glue Records use wrong IPv4

I was having trouble with DNSSEC the other day with my mailinabox on v57.1, so I decided to upgrade to v60 and Ubuntu 22 to see if that would fix it, I’m still not sure on that part, however, in the process a much larger issue has appeared.

When I initially set up the box it used the server’s default IPv4 and IPv6 address, however I have a different IPv4 which I then set up and rebooted the box with and then ran sudo mailinabox to update the IPv4 address - it shows the correct one when the mailinabox command is run after I switched it, however the Glue records continue to use the old IPv4 (which is now disabled on this box), causing the DNS to fail every time I switch it to be handled by the mail-in-a-box. I’ve tried all the steps recommended in the troubleshooting section and I’m not sure how to get this to work again?

In the MIAB dashboard when I switch the nameservers to my box, it shows the “Nameserver records aren’t correct at registrar”.

Any advice appreciated.

You changed the IPv4 that the box is running on, did you change IP on the Glue record at the registrar?

What was the issue with DNSSEC? Hopefully you disabled it before migrating to v60…

I have DNSSEC disabled at the moment, the glue record at my registrar is correct with the New IP (as that’s the one I’ve always used for mailinabox) but when I switch it over to mailinabox DNS, the mailinabox server reports the Glue records at the wrong IP. I have checked multiple times and they’re definately correct at the registrar (and the status page agrees when I have my registrar’s DNS set)

It was only due to the flashing of a fresh Ubuntu 22 image that it temporarily reverted back to the Old (default) IP.

Are you using the external DNS of your registrar or the internal DNS of mailinabox? Having just done the upgrade myself, I advise you to use the internal DNS of your box. Set the glue records at the registrar and be done with it.

Mailinabox has nothing to do with Glue records.

I think you mean to say that MiaB reports the incorrect IP address for the name servers ns1 and ns2?

Please rerun sudo mailinabox and be certain that it picks up the correct IP address. I suspect that you may not have updated MiaB when you changed IP’s.

Oh and please PM me your domain name so I can check DNS just in case something else is going on.

I was using the internal DNS but it seemed to be causing issues (domain not resolveable) so I switched back to my registrar’s DNS

I just reran it and it’s definitely using the correct IP address.

I can’t find the button to message you (maybe because I only signed up today?) but my domain is

I’ve moved my DNS back to the mail-in-a-box so you can see it in the state where it’s warning me about the glue records. Maybe it is just the DNSSEC issue rearing its head again as it works fine on all my mobile devices but not my desktop where DNSSEC is enforced.

I will attach a photo of my dashboard in just a second.

Back from where? …

My registrar, where it was as mailinabox shows these issues when pointing at the mail-in-a-box dns (it’s green when I use registrar DNS).

For some reason I cannot log in to my usual account here …

Please share the result of

sudo service nsd status

Do you have any CNAME records for the domain ? If so what are they?

Delete them (temporarily) from the Custom DNS page.

I’ve removed them all and restarted nsd and it’s no longer showing any errors. I suspected it might be the last one due to the punycode but I removed just that one and it was still spitting out errors so I removed the rest.

One more (wouldn’t let me embed two images in one post)

Seems it’s now reporting the correct ip when I do a NSLOOKUP.

That’s it fixed now it seems, thanks everyone for your help! :slight_smile:

What does sudo service nsd status look like now?

Oh and can we move this to Slack, a place more conducive to real time communication? :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.