After Upgrade to 0.28: Email -> Error Provisioning TLS Certificate

every morning i get an email with the title “Error Provisioning TLS Certificate”.
The content of the email is
“* Reloading nginx configuration nginx
web updated”

When i check the certificates with ./ -q --> empty no feedback…
(i found in the

Starting ./ i get for all of my domains --> skipped: xxxxxxx. The domain has a valid certificate already.

Any ideas?

Thx a lot.

I have seen two or three people with the same complaint … perhaps there is some bug in the newest version …


same here ! upgrade to v0.28 moved to cerbot for generating certificat but it need registration with an email address first that the miab update do not provide or let us insert !
email alert for generating certs:
Provisioning TLS certificates for ******.*****.mail, .maill, www..mail.
error: *********.*********.mail, *.mail, www..mail:
Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator webroot, Installer None
You should register before running non-interactively, or provide --agree-tos and --email <email_address> flags.

Error in end of miab install script !

I also have this exact problem

there seems to be a problem with the new certificate script, if you get that error during clean install or upgrade…
Just do a sudo mailinabox and when prompted answer Agree (A then enter), certificates will work fine then


That worked! Thank you

It’s working for me… Thx a lot!

That work for me too ! Thx !

I was having a problem with certificates being renewed also. The above worked to fix the problem for me as well. Thank You!

There is another issue: the option to generate a new certificate is missing (I moved the box to another instance, accepted the letsencrypt TOS)

Just to confirm … did you restore the data from the encrypted backup? or choose not to restore previous data?

I woke up to a non-working server, ran across this post and it worked for me, thank you!

I SCPed /home/user-data and /root/mailinabox (I was unable to run the backup, the old server was in rescue mode). Anyway the problem solved automatically overnight