Admin shows valid TLS Certificate, but not valid to outside sender

We have been using mail-in-a-box for years.
Recently, we were unable to send mail from another server using the mail-in-a-box smtp server located at The error from the outside server running PHPmailer was

Connection failed. Error #2: stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages:error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed [/var/www/html/vendor/phpformbuilder/mailer/phpmailer/src/SMTP.php line 405]
SMTP Error: Could not connect to SMTP host.

If I run:

echo QUIT | openssl s_client -starttls smtp -crlf -connect

from the outside server, it tells me the certificate has expired.

However, if I log into the admin of the box server at It says the certificate is signed and valid.

Could the outsider server be looking for the smtp server’s certificate in another location, which is why it believes it is expired?

Any help would be great.

When I run that command, I get the same certificate as the website serves, which is the expected output.

Is it possible there is a configuration issue with PHPMailer?

1 Like

It shows it is expired, correct? Why would the admin show it is current?

Also, if I test the url using sslabs, it shows it is current

PHPMailer is on the outside server, and it worked for a long time. It is part of a form that sends the responses to an email address.


The certificate is valid.

1 Like

So why does that command say the cert is expired? And when I try to connect to the smtp server from the outside server, it fails?
Could it be looking at a different certificate somehow? How can I tell it to look at the correct certificate?

it was an outdated version of openssl on the outside server. Thanks for your help, would not have figured that out without you.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.